diff mbox series

[bug#50213,10/19] gnu: python-werkzeug: Disable tests that require networking.

Message ID 20210826151553.10127-10-jgart@dismail.de
State New
Headers show
Series [bug#50213,01/19] gnu: python-pytest-6: Update to 6.2.4. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

jgart Aug. 26, 2021, 3:15 p.m. UTC
* gnu/packages/python-web.scm (python-werkzeug) [arguments]:
Disable tests that require an internet connection.

Co-authored-by: Raghav Gururajan <rg@raghavgururajan.name>
---
 gnu/packages/python-web.scm | 7 ++++++-
 1 file changed, 6 insertions(+), 1 deletion(-)

Comments

Efraim Flashner Aug. 26, 2021, 9:50 p.m. UTC | #1
I joined the 3 werkzeug patches together (since they seem to all be
parts of updating the package) and the tests failed for me.
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index c464c54301..07db685e2a 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -4112,8 +4112,13 @@  List.  Forked from and using the same API as the publicsuffix package.")
          (delete 'check)
          (add-after 'install 'check
            (lambda* (#:key inputs outputs #:allow-other-keys)
+             ;; requires networking
+             (for-each delete-file
+               (list "tests/middleware/test_http_proxy.py"
+                     "tests/test_serving.py"
+                     "tests/test_debug.py"))
              (add-installed-pythonpath inputs outputs)
-             (invoke "python" "-m" "pytest"))))))
+             (invoke "pytest" "-vv"))))))
     (propagated-inputs
      `(("python-requests" ,python-requests)))
     (native-inputs