diff mbox series

[bug#50213] gnu: python-flask: Add missing propagated-inputs.

Message ID 20210826150820.8836-1-jgart@dismail.de
State New
Headers show
Series [bug#50213] gnu: python-flask: Add missing propagated-inputs. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

jgart Aug. 26, 2021, 3:08 p.m. UTC
* gnu/packages/python-web.scm (python-flask) [propagated-inputs]:
Add python-markupsafe, python-asgiref, and python-dotenv.
---
 gnu/packages/python-web.scm | 3 +++
 1 file changed, 3 insertions(+)

Comments

jgart Aug. 26, 2021, 3:21 p.m. UTC | #1
Hi,

Ignore the first lone patch. It's a duplicate. I "pushed the button" too quickly with git send-email :)

This patch set upgrades flask to 2.0.1.

https://flask.palletsprojects.com/en/2.0.x/changes/#version-2-0-1

all best,

jgart
jgart Sept. 1, 2021, 3:24 a.m. UTC | #2
Hi Efraim,

I updated the patchset and squashed some of the commits that can be logically grouped together as a single commit.

I removed python-pytest-6 from the patch set since Maxim updated it since then in 66071cd85ea323292eb60258d3cef9ffaf8306d4.

I tested this new patch set and everything builds fine for me. Let me know if builds are still failing for you.

all best,

jgart
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index eefdb751a7..938b93a4ba 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -2998,6 +2998,9 @@  minimum of WSGI.")
     (propagated-inputs
      `(("python-itsdangerous" ,python-itsdangerous)
        ("python-jinja2" ,python-jinja2)
+       ("python-markupsafe" ,python-markupsafe)
+       ("python-asgiref" ,python-asgiref)
+       ("python-dotenv" ,python-dotenv)
        ("python-click" ,python-click)
        ("python-werkzeug" ,python-werkzeug)))
     (home-page "https://www.palletsprojects.com/p/flask/")