diff mbox series

[bug#50157,v2,2/2] gnu: Add xpadneo.

Message ID 20210826111035.20464-2-leo.prikler@student.tugraz.at
State Accepted
Headers show
Series [bug#50157,v2,1/2] build-system: linux-module: Support source-directory. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Leo Prikler Aug. 26, 2021, 11:10 a.m. UTC
* gnu/packages/linux.scm (xpadneo): New variable.
---
 gnu/packages/linux.scm | 35 +++++++++++++++++++++++++++++++++++
 1 file changed, 35 insertions(+)

Comments

Leo Prikler Sept. 14, 2021, 10:03 p.m. UTC | #1
Going by the lack of replies, I'll assume that v2 addressed all
concerns of v1 and therefore pushed this.

Regards
diff mbox series

Patch

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 7b92be4b9c..4383048403 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1505,6 +1505,41 @@  allows some more serious things like adding streaming capabilities to an
 application by hooking GStreamer into the loopback device.")
     (license license:gpl2+)))
 
+(define-public xpadneo
+  (package
+    (name "xpadneo")
+    (version "0.9.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/atar-axis/xpadneo")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0xr0zx134s56h4ij6c3fh8ki0h58h61minbfxcl3sgpgxkh14ism"))))
+    (build-system linux-module-build-system)
+    (arguments
+     `(#:tests? #f ; no `check' target
+       #:source-directory "hid-xpadneo/src"
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'install 'post-install
+           (lambda* (#:key outputs #:allow-other-keys #:rest args)
+             (let ((out (assoc-ref outputs "out")))
+               (copy-recursively "hid-xpadneo/etc-modprobe.d"
+                                 (string-append out "/etc/modprobe.d"))
+               (copy-recursively "hid-xpadneo/etc-udev-rules.d"
+                                 (string-append out "/etc/udev/rules.d"))))))))
+    (home-page "https://atar-axis.github.io/xpadneo/")
+    (synopsis "Xbox One Wireless Controller driver")
+    (description
+     "This package provides a driver for the XBox One S Wireless controller
+and some newer models when connected via bluetooth.  In addition to the kernel
+module provided itself, it also contains a modprobe configuration and udev
+rules, which need to be installed separately.")
+    (license license:gpl3+)))
+
 
 ;;;
 ;;; Pluggable authentication modules (PAM).