diff mbox series

[bug#50135,core-updates-frozen] gnu: appstream-glib: Fix failing tests.

Message ID 20210820135526.15381-1-maximedevos@telenet.be
State Accepted
Headers show
Series [bug#50135,core-updates-frozen] gnu: appstream-glib: Fix failing tests. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

M Aug. 20, 2021, 1:55 p.m. UTC
* gnu/packages/glib.scm
  (appstream-glib)[arguments]<#:phases>{set-home}: Set the $HOME
  environment variable.
---
 gnu/packages/glib.scm | 6 +++++-
 1 file changed, 5 insertions(+), 1 deletion(-)


base-commit: c9484c9c9944f65a69cf6182caf442d9285f3a65

Comments

Leo Famulari Aug. 20, 2021, 7:07 p.m. UTC | #1
On Fri, Aug 20, 2021 at 03:55:26PM +0200, Maxime Devos wrote:
> * gnu/packages/glib.scm
>   (appstream-glib)[arguments]<#:phases>{set-home}: Set the $HOME
>   environment variable.

Thanks! As discussed on #guix IRC, I changed it to use /tmp instead of
(getcwd), and pushed as a24631a6dfc765c1e4e3f56cca51bd12672e8726.
diff mbox series

Patch

diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index ae88dbe9e7..b382d530d8 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -1101,7 +1101,11 @@  Some codes examples can be find at:
            (lambda _
              (substitute* "libappstream-glib/as-self-test.c"
                (("g_test_add_func.*as_test_store_local_appdata_func);") ""))
-             #t)))))
+             #t))
+         (add-before 'check 'set-home
+           (lambda _
+             ;; Some tests want write access there.
+             (setenv "HOME" (getcwd)))))))
     (home-page "https://github.com/hughsie/appstream-glib")
     (synopsis "Library for reading and writing AppStream metadata")
     (description "This library provides objects and helper methods to help