diff mbox series

[bug#50081,core-updates-frozen,v3] gnu: texlive-texmf: Disable LuaJIT engines on powerpc64le

Message ID 20210820004715.21077-1-bauermann@kolabnow.com
State Accepted
Headers show
Series [bug#50081,core-updates-frozen,v3] gnu: texlive-texmf: Disable LuaJIT engines on powerpc64le | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Thiago Jung Bauermann Aug. 20, 2021, 12:47 a.m. UTC
LuaJIT isn’t ported to 64-bit PowerPC. ‘texlive-bin’ and
‘texlive-latex-base’ already disable the engines that rely on it, so just
do the same in texlive-texmf.

Fix suggested by Mathieu Othacehe <othacehe@gnu.org>.

Also, for consistency use ‘target-ppc64le’ in ‘texlive-bin’ as well.

* gnu/packages/tex.scm (texlive-bin)[arguments]<#:configure-flags>: Use
‘target-ppc64le’.
(texlive-texmf)[arguments]<#:phases>{texmf-config}:
Disable LuaJIT engines when building for powerpc64le.
---

Hello,

This fixes the build of ‘texlive-texmf’ on powerpc64le. It was failing
with these errors:

  fmtutil [ERROR]: not building luajittex due to missing engine: luajittex
  fmtutil [ERROR]: not building luajithbtex due to missing engine: luajithbtex

Thank you very much to Mathieu for his help in making  this work.

Changes since v2:
- Use ‘target-ppc64le?’ to match target string.
- Change ‘texlive-bin’ to also use ‘target-ppc64le?’.

Changes since v1:
- Match target with “powerpc64” prefix rather than “powerpc64le”.

 gnu/packages/tex.scm | 9 +++++++--
 1 file changed, 7 insertions(+), 2 deletions(-)

Comments

Efraim Flashner Aug. 22, 2021, 11:19 a.m. UTC | #1
I took out the unrelated patch to texlive-bin and pushed the part for
texlive-texmf.
Thiago Jung Bauermann Aug. 22, 2021, 10:49 p.m. UTC | #2
Hello Efraim,

Em domingo, 22 de agosto de 2021, às 08:19:48 -03, Efraim Flashner 
escreveu:
> I took out the unrelated patch to texlive-bin

Ok. Do you think it’s worth submitting that part separately, or is it just 
unnecessary code churn?

> and pushed the part for texlive-texmf.

Thank you!
Efraim Flashner Aug. 23, 2021, 6:19 a.m. UTC | #3
On Sun, Aug 22, 2021 at 07:49:45PM -0300, Thiago Jung Bauermann wrote:
> Hello Efraim,
> 
> Em domingo, 22 de agosto de 2021, às 08:19:48 -03, Efraim Flashner 
> escreveu:
> > I took out the unrelated patch to texlive-bin
> 
> Ok. Do you think it’s worth submitting that part separately, or is it just 
> unnecessary code churn?
> 
> -- 
> Thanks,
> Thiago
> 

I'd leave it and wait for it to get touched the next time. Its like
removing the trailing #t in core-updates, when we're already doing
something to the package is a good time to make the change.
diff mbox series

Patch

diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 4500f1929264..9ec015482808 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -339,8 +339,7 @@  files from LOCATIONS with expected checksum HASH.  CODE is not currently in use.
          "--with-system-zlib"
          "--with-system-zziplib"
          ;; LuaJIT is not ported to powerpc64le* yet.
-         ,@(if (string-prefix? "powerpc64le" (or (%current-target-system)
-                                                 (%current-system)))
+         ,@(if (target-ppc64le?)
                '("--disable-luajittex"
                  "--disable-luajithbtex"
                  "--disable-mfluajit")
@@ -6829,9 +6828,15 @@  directly generate PDF documents instead of DVI.")
                      (share (string-append out "/share"))
                      (texmfroot (string-append share "/texmf-dist/web2c"))
                      (texmfcnf (string-append texmfroot "/texmf.cnf"))
+                     (fmtutilcnf (string-append texmfroot "/fmtutil.cnf"))
                      (texlive-bin (assoc-ref inputs "texlive-bin"))
                      (texbin (string-append texlive-bin "/bin"))
                      (tlpkg (string-append texlive-bin "/share/tlpkg")))
+                ;; LuaJIT is not ported to powerpc64* yet.
+                (if ,(target-ppc64le?)
+                    (substitute* fmtutilcnf
+                      (("^(luajittex|luajithbtex|mfluajit)" m)
+                       (string-append "#! " m))))
                 ;; Register SHARE as TEXMFROOT in texmf.cnf.
                 (substitute* texmfcnf
                   (("TEXMFROOT = \\$SELFAUTOPARENT")