diff mbox series

[bug#50117,2/2] gnu: go-github-com-aswinkarthik-csvdiff: Make inputs native.

Message ID 20210819072156.90545-3-me@bonfacemunyoki.com
State Accepted
Headers show
Series go-github-com-aswinkarthik-csvdiff package updates | expand

Commit Message

Munyoki Kilyungi Aug. 19, 2021, 7:21 a.m. UTC
* gnu/packages/golang.scm (go-github-com-aswinkarthik-csvdiff)
[propagated-inputs]: Make these inputs native. Typically end-user Go packages
will want inputs/native-inputs rather than propagated inputs unless the input
provides a binary used at runtime, so user profiles are not
cluttered (go-build-system needs source from all transitive dependencies).
---
 gnu/packages/golang.scm | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 8a8830a6f6..7b151a03e3 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -8439,7 +8439,7 @@  non-cryptographic hash algorithm, working at speeds close to RAM limits.")
     (build-system go-build-system)
     (arguments
      '(#:import-path "github.com/aswinkarthik/csvdiff"))
-    (propagated-inputs
+    (native-inputs
      `(("go-golang-org-x-sys" ,go-golang-org-x-sys)
        ("go-github-com-stretchr-testify" ,go-github-com-stretchr-testify)
        ("go-github-com-spf13-cobra" ,go-github-com-spf13-cobra)