diff mbox series

[bug#50099] gnu: dconf: Increase test timeout further.

Message ID 20210817193104.691-1-timotej.lazar@araneo.si
State New
Headers show
Series [bug#50099] gnu: dconf: Increase test timeout further. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Timotej Lazar Aug. 17, 2021, 7:31 p.m. UTC
The “engine” test hit the previous 90 s time limit when cross-compiling on a
less powerful machine.

* gnu/packages/gnome.scm (dconf)[arguments]: Change timeout to 300 s in
'increase-test-timeout phase. Drop trailing #t.
---
 gnu/packages/gnome.scm | 3 +--
 1 file changed, 1 insertion(+), 2 deletions(-)

Comments

phodina Oct. 30, 2021, 9:08 p.m. UTC | #1
Hi Timotej,

thanks for the patch! I was cross-compiling (x86_64 -> aarch64) the dconf package as dependency and found myself in the same position.

The tests were failing on my laptop. Increasing the timeout solves the problem.

Could I ask someone pretty please to apply it to master?

Petr
Tobias Geerinckx-Rice Oct. 31, 2021, 11:03 a.m. UTC | #2
Timotej, Petr,

phodina via Guix-patches via 写道:
> Could I ask someone pretty please to apply it to master?

Dun.  Thanks, and sorry for the delay!

Kind regards,

T G-R
diff mbox series

Patch

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 98c121ac22..2696c958e0 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -4573,8 +4573,7 @@  and RDP protocols.")
                       ;; much longer than the default of 30 seconds.
                       (substitute* "tests/meson.build"
                         (("test\\(unit_test\\[0\\], exe" all)
-                         (string-append all ", timeout : 90")))
-                      #t)))))
+                         (string-append all ", timeout: 300"))))))))
     (home-page "https://developer.gnome.org/dconf/")
     (synopsis "Low-level GNOME configuration system")
     (description "Dconf is a low-level configuration system.  Its main purpose