diff mbox series

[bug#50076,1/1] gnu: Add python-flask-debugtoolbar.

Message ID 20210816095059.10480-1-me@bonfacemunyoki.com
State New
Headers show
Series Add python-flask-debugtoolbar. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Munyoki Kilyungi Aug. 16, 2021, 9:50 a.m. UTC
* gnu/packages/python-web.scm (python-flask-debugtoolbar): New variable.
---
 gnu/packages/python-web.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)

Comments

Arun Isaac Aug. 23, 2021, 8:53 p.m. UTC | #1
Hi Bonface,

Thanks for contributing! :-) Some feedback follows.

1. Please add a copyright header.
2. Could you try packaging the tests? I think tests use
pytest. Currently, no tests are run during the check phase.

> +  (synopsis
> +    "A toolbar overlay for debugging Flask applications.")

3. Could you remove the article "A" at the beginning, and the period at
the end? Quoting from our manual at "(guix) Synopses and Descriptions":

--8<---------------cut here---------------start------------->8---
   Synopses must start with a capital letter and must not end with a
period.  They must not start with “a” or “the”, which usually does not
bring anything; for instance, prefer “File-frobbing tool” over “A tool
that frobs files”.
--8<---------------cut here---------------end--------------->8---

> +  (description
> +    "This extension adds a toolbar overlay to Flask applications containing
> +useful information for debugging.")

4. Finally, a nitpick: It would be more consistent with the rest of Guix
if the synopsis and description started on the same line instead of on
the next. So, something like this:

--8<---------------cut here---------------start------------->8---
    (description "This extension adds a toolbar overlay to Flask applications
containing useful information for debugging.")
--8<---------------cut here---------------end--------------->8---

Thanks!
Arun
Munyoki Kilyungi Aug. 27, 2021, 11:14 a.m. UTC | #2
Arun Isaac <arunisaac@systemreboot.net> anaandika:

> Hi Bonface,
>
> Thanks for contributing! :-) Some feedback follows.
>
> 1. Please add a copyright header.

Cool. Thanks for the gentle reminder.

> 2. Could you try packaging the tests? I think tests use
> pytest. Currently, no tests are run during the check phase.
>

Cool. I'll try to work out how to do that.

>> +  (synopsis
>> +    "A toolbar overlay for debugging Flask applications.")
>
> 3. Could you remove the article "A" at the beginning, and the period at
> the end? Quoting from our manual at "(guix) Synopses and Descriptions":
>
>    Synopses must start with a capital letter and must not end with a
> period.  They must not start with “a” or “the”, which usually does not
> bring anything; for instance, prefer “File-frobbing tool” over “A tool
> that frobs files”.
>
>
>> +  (description
>> +    "This extension adds a toolbar overlay to Flask applications containing
>> +useful information for debugging.")
>
> 4. Finally, a nitpick: It would be more consistent with the rest of Guix
> if the synopsis and description started on the same line instead of on
> the next. So, something like this:
>
>     (description "This extension adds a toolbar overlay to Flask applications
> containing useful information for debugging.")
>

Much thanks for the above suggestions! I'll work
on this and submit a revised patch over the
weekend.

-- 
Bonface M. K. D4F09EB110177E03C28E2FE1F5BBAE1E0392253F
Free Software Activist
Humble GNU Emacs User | Bearer of scheme-y parens
Curator: <https://upbookclub.com> | Twitter: @BonfaceKilz
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 32b4aa4bf0..c8f0ab3940 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -3005,6 +3005,32 @@  and Jinja2 template engine.  It is called a micro framework because it does not
 presume or force a developer to use a particular tool or library.")
     (license license:bsd-3)))
 
+(define-public python-flask-debugtoolbar
+  (package
+  (name "python-flask-debugtoolbar")
+  (version "0.11.0")
+  (source
+    (origin
+      (method url-fetch)
+      (uri (pypi-uri "Flask-DebugToolbar" version))
+      (sha256
+        (base32
+          "1d5asdnk8bmh6m46pzg3i7677cjgdm9mlm3wcpk19q7dak9pjkiw"))))
+  (build-system python-build-system)
+  (propagated-inputs
+    `(("python-blinker" ,python-blinker)
+      ("python-flask" ,python-flask)
+      ("python-itsdangerous" ,python-itsdangerous)
+      ("python-werkzeug" ,python-werkzeug)))
+  (home-page
+   "https://flask-debugtoolbar.readthedocs.io/")
+  (synopsis
+    "A toolbar overlay for debugging Flask applications.")
+  (description
+    "This extension adds a toolbar overlay to Flask applications containing
+useful information for debugging.")
+  (license license:bsd-3)))
+
 (define-public python-flask-wtf
   (package
     (name "python-flask-wtf")