diff mbox series

[bug#50065] gnu: Add setroot.

Message ID 20210815064636.19182-1-brice@waegenei.re
State Accepted
Headers show
Series [bug#50065] gnu: Add setroot. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Brice Waegeneire Aug. 15, 2021, 6:46 a.m. UTC
* gnu/packages/xorg.scm (setroot): New variable.
---
 gnu/packages/xorg.scm | 33 +++++++++++++++++++++++++++++++++
 1 file changed, 33 insertions(+)


base-commit: e0feacfbad410ecb2f11e7ee86f18482c7413b3f

Comments

Mathieu Othacehe Aug. 31, 2021, 2:04 p.m. UTC | #1
Hello Brice,

> +    (source (origin

You should put origin on the next line to respect the 78 columns limit.

> +              (method git-fetch)
> +              (uri (git-reference
> +                    (url "https://github.com/ttzhou/setroot")
> +                    (commit (string-append "v" version))))
> +              (file-name (git-file-name name version))
> +              (sha256
> +               (base32 "0w95828v0splk7bj5kfacp4pq6wxpyamvyjmahyvn5hc3ycq21mq"))))
> +    (build-system gnu-build-system)
> +    (arguments
> +     '(#:make-flags
> +       (list (string-append "DESTDIR=" (assoc-ref %outputs "out"))
> +             "PREFIX="
> +             "xinerama=1")

The Makefile seems to hardcode CC to gcc which probably breaks
cross-compilation.

> +syntax without it's image viewing capabilities.  It supports multiple monitors
                    ^
                    its?

Thanks,

Mathieu
diff mbox series

Patch

diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 6f9633985e..505af87512 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -6925,3 +6925,36 @@  an existing user-specified one, writes a cookie to it, and then starts the
 the server and cleaning up before returning the exit status of the command.")
     (license (list license:x11                    ; the script
                    license:gpl2+))))              ; the man page
+
+(define-public setroot
+  (package
+    (name "setroot")
+    (version "2.0.2")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/ttzhou/setroot")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32 "0w95828v0splk7bj5kfacp4pq6wxpyamvyjmahyvn5hc3ycq21mq"))))
+    (build-system gnu-build-system)
+    (arguments
+     '(#:make-flags
+       (list (string-append "DESTDIR=" (assoc-ref %outputs "out"))
+             "PREFIX="
+             "xinerama=1")
+       #:tests? #f                      ; no tests
+       #:phases
+       (modify-phases %standard-phases
+         (delete 'configure))))
+    (inputs
+     `(("imlib2" ,imlib2)
+       ("libx11" ,libx11)
+       ("libxinerama" ,libxinerama)))
+    (home-page "https://github.com/ttzhou/setroot")
+    (synopsis "Simple X background setter inspired by imlibsetroot and feh")
+    (description "Setroot is a lightweight X background setter with feh's
+syntax without it's image viewing capabilities.  It supports multiple monitors
+and can restore previously set wallpapers and options.")
+    (license license:gpl3+)))