diff mbox series

[bug#50018,v2,19/19] gnu: Remove python2-amqp.

Message ID 20210813224524.33933-4-monego@posteo.net
State Accepted
Headers show
Series None | expand

Commit Message

Vinicius Monego Aug. 13, 2021, 10:45 p.m. UTC
* gnu/packages/python-xyz.scm (python2-amqp): Remove variable.
(python-amqp)[properties]: Remove.
---
 gnu/packages/python-xyz.scm | 13 +------------
 1 file changed, 1 insertion(+), 12 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 4c29c044fb..c8faedcf82 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -13206,18 +13206,7 @@  and provides a uniform API regardless of which JSON implementation is used.")
      "This is a fork of amqplib which was originally written by Barry Pederson.
 It is maintained by the Celery project, and used by kombu as a pure python
 alternative when librabbitmq is not available.")
-    (license license:lgpl2.1+)
-    (properties `((python2-variant . ,(delay python2-amqp))))))
-
-(define-public python2-amqp
-  (let ((amqp (package-with-python2
-               (strip-python2-variant python-amqp))))
-    (package/inherit amqp
-      (arguments `(;; Tries to run coverage tests with nose-cover3, which seems
-                   ;; unmaintained.  Weirdly, does not do this on the python 3
-                   ;; version?
-                   #:tests? #f
-                   ,@(package-arguments amqp))))))
+    (license license:lgpl2.1+)))
 
 (define-public python-txamqp
   (package