diff mbox series

[bug#50018,v2,16/19] gnu: python-celery: Enable tests.

Message ID 20210813224524.33933-1-monego@posteo.net
State Accepted
Headers show
Series None | expand

Commit Message

Vinicius Monego Aug. 13, 2021, 10:45 p.m. UTC
* gnu/packages/python-xyz.scm (python-celery)[arguments]: Remove
'patch-requirements phase. Remove #:tests?. Override 'check phase.
[native-inputs]: Add python-flaky, python-iniconfig, python-moto,
python-msgpack, python-pytest-celery, python-pytest-subtests,
python-pytest-timeout, python-toml.
---
Enabled backend tests and added python-msgpack to native-inputs. Subsequent patches are rebase only.

 gnu/packages/python-xyz.scm | 31 +++++++++++++++++++++----------
 1 file changed, 21 insertions(+), 10 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 175bab1b89..772e04f5c6 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -13344,20 +13344,31 @@  Python 2.4 and 2.5, and will draw its fixes/improvements from python-trunk.")
         (base32 "1c6lw31i3v81fyj4yn37lbvv70xdgb389iccirzyjr992vlkv6ld"))))
     (build-system python-build-system)
     (arguments
-     '(;; TODO The tests fail with Python 3.7
-       ;; https://github.com/celery/celery/issues/4849
-       #:tests? #f
-       #:phases
+     '(#:phases
        (modify-phases %standard-phases
-         (add-after 'unpack 'patch-requirements
+         (add-after 'unpack 'skip-problematic-tests
            (lambda _
-             (substitute* "requirements/test.txt"
-               (("pytest>=3\\.0,<3\\.3")
-                "pytest>=3.0"))
-             #t)))))
+             (for-each delete-file-recursively
+                       '("t/distro" ; tests requirements for CI
+                         "t/integration")))) ; hangs tests
+         (replace 'check
+           (lambda* (#:key inputs outputs tests? #:allow-other-keys)
+             (when tests?
+               (add-installed-pythonpath inputs outputs)
+               (invoke "python" "-m" "pytest" "t" "-k"
+                       ;; AssertionError.
+                       "not test_check_privileges_no_fchown")))))))
     (native-inputs
      `(("python-case" ,python-case)
-       ("python-pytest" ,python-pytest)))
+       ("python-flaky" ,python-flaky)
+       ("python-iniconfig" ,python-iniconfig)
+       ("python-moto" ,python-moto)
+       ("python-msgpack" ,python-msgpack)
+       ("python-pytest" ,python-pytest-6)
+       ("python-pytest-celery" ,python-pytest-celery)
+       ("python-pytest-subtests" ,python-pytest-subtests)
+       ("python-pytest-timeout" ,python-pytest-timeout)
+       ("python-toml" ,python-toml)))
     (propagated-inputs
      `(("python-billiard" ,python-billiard)
        ("python-boto3" ,python-boto3)