diff mbox series

[bug#49643,1/2] gnu: Add z80asm

Message ID 20210813143156.16449-1-thomas@thomaslabs.org
State New
Headers show
Series [bug#49643,1/2] gnu: Add z80asm | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Thomas Albers Raviola Aug. 13, 2021, 2:31 p.m. UTC
From: Thomas Albers <tgalbers2000@gmail.com>

---
 gnu/packages/assembly.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/assembly.scm b/gnu/packages/assembly.scm
index 51c0572674..a60370ad8d 100644
--- a/gnu/packages/assembly.scm
+++ b/gnu/packages/assembly.scm
@@ -533,3 +533,31 @@  family of command line utility wrappers in the default output.  Each of the cli
 tools is named like @code{xed*}.  Documentation for the cli tools is sparse, so
 this is a case where ``the code is the documentation.''")
     (license license:asl2.0)))
+
+(define-public z80asm
+  (package
+    (name "z80asm")
+    (version "1.8")
+    (source
+     (origin
+       (uri "http://download.savannah.nongnu.org/releases/z80asm/z80asm-1.8.tar.gz")
+       (sha256
+        (base32 "0r2za4qb7b0n13xksj6vwddixn2jzcc5h8qk06kxzkc20naakyv7"))
+       (method url-fetch)))
+    (build-system gnu-build-system)
+    (arguments
+     '(#:phases
+       (modify-phases %standard-phases
+         (delete 'configure)
+         (delete 'check)
+         (replace 'install
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let ((bin (string-append (assoc-ref outputs "out")
+                                       "/bin")))
+               (install-file "z80asm" bin)
+               #t))))))
+    (synopsis "Assembler for the Z80 microprocessor")
+    (description "Assembler for the Z80 microprocessor which supports all
+official mnemonics together with many unofficial ones.")
+    (home-page "http://savannah.nongnu.org/projects/z80asm")
+    (license license:gpl3)))