diff mbox series

[bug#50033,3/4] gnu: Add python-flask-caching.

Message ID 20210812235807.26857-3-monego@posteo.net
State New
Headers show
Series Add Isso. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Vinicius Monego Aug. 12, 2021, 11:58 p.m. UTC
* gnu/packages/python-web.scm (python-flask-caching): New variable.
---
 gnu/packages/python-web.scm | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 5df134ddff..36e1bf7541 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1018,6 +1018,37 @@  support for Flask.  This is based on the Python babel module as well as pytz -
 both of which are installed automatically if you install this library.")
     (license license:bsd-3)))
 
+(define-public python-flask-caching
+  (package
+    (name "python-flask-caching")
+    (version "1.10.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "Flask-Caching" version))
+       (sha256
+        (base32 "000wl24ig22yzvx3dkl3yv5z0lzd6asmaz5fwh1vmhpbzhibf6fg"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda* (#:key inputs outputs tests? #:allow-other-keys)
+             (when tests?
+               (add-installed-pythonpath inputs outputs)
+               (invoke "python" "-m" "pytest" "-k"
+                       "not test_init_nullcache")))))))
+    (native-inputs
+     `(("python-flask" ,python-flask)
+       ("python-memcached" ,python-memcached)
+       ("python-pytest" ,python-pytest)
+       ("python-pytest-cov" ,python-pytest-cov)))
+    (home-page "https://github.com/sh4nks/flask-caching")
+    (synopsis "Caching extension for Flask")
+    (description "This package adds caching support to Flask.  It is a fork of
+the Flask-Cache extension.")
+    (license license:bsd-3)))
+
 (define-public python-flask-cors
   (package
     (name "python-flask-cors")