diff mbox series

[bug#50021,4/7] gnu: python-translate-toolkit: Update to 3.3.6.

Message ID 20210812013123.44869-4-monego@posteo.net
State Accepted
Headers show
Series Update python-translate-toolkit. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Vinicius Monego Aug. 12, 2021, 1:31 a.m. UTC
* gnu/packages/python-xyz.scm (python-translate-toolkit): Update to 3.3.6.
[propagated-inputs]: Remove python-babel, python-beautifulsoup4,
python-chardet, python-diff-match-patch, python-levenshtein, python-lxml,
python-six, python-vobject, python-pyyaml.
---
 gnu/packages/python-xyz.scm | 16 ++++------------
 1 file changed, 4 insertions(+), 12 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 22341eda37..a92f4ebc67 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -17764,33 +17764,25 @@  when data is updated.
 (define-public python-translate-toolkit
   (package
     (name "python-translate-toolkit")
-    (version "2.1.0")
+    (version "3.3.6")
     (source
      (origin
        (method url-fetch)
-       (uri (pypi-uri "translate-toolkit" version ".tar.bz2"))
+       (uri (pypi-uri "translate-toolkit" version ".tar.gz"))
        (sha256
-        (base32 "1vlkwrg83vb17jc36pmwh2b7jphwf390lz0jw8hakcg16qhwypvq"))))
+        (base32 "0q0qvs4sk1yhbsl9ja8ivvw0083bvfylbhnbbnx17833qmd83imb"))))
     (build-system python-build-system)
     (native-inputs
      `(("python-pytest" ,python-pytest)
        ("python-sphinx" ,python-sphinx)))
     (propagated-inputs
-     `(("python-babel" ,python-babel)
-       ("python-beautifulsoup4" ,python-beautifulsoup4)
-       ("python-chardet" ,python-chardet)
-       ("python-diff-match-patch" ,python-diff-match-patch)
-       ("python-levenshtein" ,python-levenshtein)
-       ("python-lxml" ,python-lxml)
-       ("python-six" ,python-six)
-       ("python-vobject" ,python-vobject)
-       ("python-pyyaml" ,python-pyyaml)))
     (arguments
      ;; TODO: tests are not run, because they end with
      ;; TypeError: parse() missing 2 required positional arguments: 'tree' and
      ;; 'parse_funcs'
      ;; during test setup.
      `(#:tests? #f))
+     `(("python-lxml" ,python-lxml)))
     (home-page "https://toolkit.translatehouse.org")
     (synopsis "Tools and API for translation and localization engineering")
     (description