diff mbox series

[bug#49900] gnu: wine: Update to 6.14.

Message ID 20210805191005.20997-1-leo.prikler@student.tugraz.at
State Accepted
Headers show
Series [bug#49900] gnu: wine: Update to 6.14. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Leo Prikler Aug. 5, 2021, 7:10 p.m. UTC
* gnu/packages/wine.scm (wine): Update to 6.14.
[#:phases]: Patch Makefile to correctly locate ntdll.so.
(wine64)[#:phases]: Likewise.
---
 gnu/packages/wine.scm | 24 +++++++++++++++++++++---
 1 file changed, 21 insertions(+), 3 deletions(-)

Comments

Leo Prikler Aug. 30, 2021, 4:25 p.m. UTC | #1
Done and updated to 6.16.

If you received this twice, pardon the resend.
diff mbox series

Patch

diff --git a/gnu/packages/wine.scm b/gnu/packages/wine.scm
index 5c6d02eec5..fccdc186d2 100644
--- a/gnu/packages/wine.scm
+++ b/gnu/packages/wine.scm
@@ -75,7 +75,7 @@ 
 (define-public wine
   (package
     (name "wine")
-    (version "6.8")
+    (version "6.14")
     (source
      (origin
        (method url-fetch)
@@ -87,7 +87,7 @@ 
               (string-append "https://dl.winehq.org/wine/source/" dir
                              "wine-" version ".tar.xz")))
        (sha256
-        (base32 "1n7bd6kkhfgi23bz981qml3lajgvbs3ibqrc2mqjhhfqczg2shjv"))))
+        (base32 "00jjqbl0xzsp2swzxgx3a2b16p26qbxvcz82a7ihig23k69p3d34"))))
     (build-system gnu-build-system)
     (native-inputs
      `(("bison" ,bison)
@@ -194,7 +194,16 @@ 
                (substitute* "include/config.h"
                  (("(#define SONAME_.* )\"(.*)\"" _ defso soname)
                   (format #f "~a\"~a\"" defso (find-so soname))))
-               #t))))))
+               #t)))
+         (add-after 'patch-generated-file-shebangs 'patch-makefile
+           (lambda* (#:key outputs #:allow-other-keys)
+             (invoke "make" "Makefile") ; Makefile is first regenerated
+             (substitute* "Makefile"
+               (("-lntdll" id)
+                (string-append id
+                               " -Wl,-rpath=" (assoc-ref outputs "out")
+                               "/lib/wine32/wine/$(ARCH)-unix")))
+             #t)))))
     (home-page "https://www.winehq.org/")
     (synopsis "Implementation of the Windows API (32-bit only)")
     (description
@@ -254,6 +263,15 @@  integrate Windows applications into your desktop.")
                       #t)))))
              (_
               `()))
+         (add-after 'patch-generated-file-shebangs 'patch-makefile
+           (lambda* (#:key outputs #:allow-other-keys)
+             (invoke "make" "Makefile") ; Makefile is first regenerated
+             (substitute* "Makefile"
+               (("-lntdll" id)
+                (string-append id
+                               " -Wl,-rpath=" (assoc-ref outputs "out")
+                               "/lib/wine64/wine/$(ARCH)-unix")))
+             #t))
          (add-after 'install 'copy-wine32-binaries
            (lambda* (#:key outputs #:allow-other-keys)
              (let* ((wine32 (assoc-ref %build-inputs "wine"))