diff mbox series

[bug#49882] gnu: mpc-boot: Use gmp-boot and mpfr-boot as dependencies

Message ID 20210804221641.230621-1-bauermann@kolabnow.com
State Accepted
Headers show
Series [bug#49882] gnu: mpc-boot: Use gmp-boot and mpfr-boot as dependencies | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Thiago Jung Bauermann Aug. 4, 2021, 10:16 p.m. UTC
MPC 1.0 is incompatible with current versions of GMP and MPFR so use the
older ‘gmp-boot’ and ‘mpfr-boot’ packages as dependencies.

* gnu/packages/commencement.scm (mpc-boot)[propagated-inputs]: Add gmp-boot
and mpfr-boot.
---

Hello,

This fixes the build of mpc-boot on powerpc64le-linux on both master
and core-updates-frozen.  The patch applies cleanly on both branches.

I believe it will also do the same for x86_64-linux and i686-linux but
I wasn’t able to verify because guix was consuming too much memory for
my laptop.

I’ve been suggesting that these patches for gmp-boot, mpfr-boot and
mpc-boot be applied to the master branch because
`guix refresh -l $PACKAGE` shows that there are no dependants on these
packages.  But it just occurred to me that perhaps this may be a
limitation in ‘guix refresh’?


 gnu/packages/commencement.scm | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index f8973392262f..c49428515eae 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -1882,7 +1882,9 @@  ac_cv_c_float_format='IEEE (little-endian)'
                     "mirror://gnu/mpc/mpc-" version ".tar.gz"))
               (sha256
                (base32
-                "1hzci2zrrd7v3g1jk35qindq05hbl0bhjcyyisq9z209xb3fqzb1"))))))
+                "1hzci2zrrd7v3g1jk35qindq05hbl0bhjcyyisq9z209xb3fqzb1"))))
+    (propagated-inputs `(("gmp" ,gmp-boot)              ; <mpc.h> refers to both
+                         ("mpfr" ,mpfr-boot)))))
 
 (define gcc-core-mesboot1
   ;; GCC 4.6.4 is the latest modular distribution.  This package is not