diff mbox series

[bug#49871,1/3] gnu: endless-sky: Update to 0.9.14.

Message ID 20210804104932.2469-1-timotej.lazar@araneo.si
State Accepted
Headers show
Series Update endless-sky | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Timotej Lazar Aug. 4, 2021, 10:49 a.m. UTC
* gnu/packages/games.scm (endless-sky): Update to 0.9.14.
[arguments]: Add 'use-gcc-ar phase to support LTO used by the new version.
---
 gnu/packages/games.scm | 9 ++++++---
 1 file changed, 6 insertions(+), 3 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index ad48c49566..792ff64a07 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -8351,7 +8351,7 @@  your score gets higher, you level up and the blocks fall faster.")
 (define-public endless-sky
   (package
     (name "endless-sky")
-    (version "0.9.12")
+    (version "0.9.14")
     (source
       (origin
         (method git-fetch)
@@ -8360,7 +8360,7 @@  your score gets higher, you level up and the blocks fall faster.")
                (commit (string-append "v" version))))
         (file-name (git-file-name name version))
         (sha256
-         (base32 "18nkl4s3r5sy3sd9lhbdg9160c7fggklklprx0d5azifc8g6k0wj"))))
+         (base32 "12iganf8dxiyrjznnabsarxjsr0h717j3k4mz15p0k67wxyahhmf"))))
     (build-system scons-build-system)
     (arguments
      `(#:scons ,scons-python2
@@ -8382,7 +8382,10 @@  your score gets higher, you level up and the blocks fall faster.")
                 "Environment(ENV = os.environ)")
                ;; Install into %out/bin
                (("games\"") "bin\""))
-             #t)))))
+             #t))
+         (add-before 'build 'use-gcc-ar
+           ;; Use gcc-ar to support LTO.
+           (lambda _ (setenv "AR" "gcc-ar") #t)))))
     (inputs
      `(("glew" ,glew)
        ("libjpeg" ,libjpeg-turbo)