diff mbox series

[bug#49816] gnu: audacious: Update to 4.1.

Message ID 20210801221446.34588-1-felgru@posteo.net
State Accepted
Headers show
Series [bug#49816] gnu: audacious: Update to 4.1. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Felix Gruber Aug. 1, 2021, 10:14 p.m. UTC
* gnu/packages/music.scm (audacious): Update to 4.1.
[inputs]: Add gtk+-2 and replace libmodplug with libopenmpt.
---
 gnu/packages/music.scm | 10 ++++++----
 1 file changed, 6 insertions(+), 4 deletions(-)

Comments

Nicolas Goaziou Aug. 5, 2021, 7 a.m. UTC | #1
Hello,

Felix Gruber <felgru@posteo.net> writes:

> * gnu/packages/music.scm (audacious): Update to 4.1.
> [inputs]: Add gtk+-2 and replace libmodplug with libopenmpt.

Thank you.

Why do you add gtk+-2 as an input? There's a more recent Qt UI. You
might want to consider adding audacious-gtk package instead.

WDYT?

Regards,
Felix Gruber Aug. 5, 2021, 5:02 p.m. UTC | #2
Hello Nicolas,

On 8/5/21 9:00 AM, Nicolas Goaziou wrote:
> Why do you add gtk+-2 as an input? There's a more recent Qt UI. You
> might want to consider adding audacious-gtk package instead.

I've added gtk+-2 as an input as otherwise the configure script failed
with the following error:

```
checking for GTK... no
configure: error: Package requirements (gtk+-2.0 >= 2.24) were not met:

No package 'gtk+-2.0' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables GTK_CFLAGS
and GTK_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
```

I've thought that GTK+ had become a required dependency, but now that
you've asked, I've looked a bit closer and apparently one can still
disable it by passing `--disable-gtk` to the configure script.

I'll send an updated patch without gtk+-2 input.

Best regards,
Felix
diff mbox series

Patch

diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 9c69204610..ef9f78ffbe 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -40,6 +40,7 @@ 
 ;;; Copyright © 2021 Frank Pursel <frank.pursel@gmail.com>
 ;;; Copyright © 2021 Rovanion Luckey <rovanion.luckey@gmail.com>
 ;;; Copyright © 2021 Justin Veilleux <terramorpha@cock.li>
+;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -177,14 +178,14 @@ 
 (define-public audacious
   (package
     (name "audacious")
-    (version "4.0.5")
+    (version "4.1")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "https://distfiles.audacious-media-player.org/"
                            "audacious-" version ".tar.bz2"))
        (sha256
-        (base32 "028zjgz0p7ys15lk2a30m5zcv9xrx3ga50wjsh4m4zxilgkakbji"))))
+        (base32 "0p734psjjvjcmla2hg5h6a9v1prvy63jj9xm2g2ngs49jy7qan0z"))))
     (build-system gnu-build-system)
     (arguments
      `(#:configure-flags
@@ -228,12 +229,13 @@ 
            (uri (string-append "https://distfiles.audacious-media-player.org/"
                                "audacious-plugins-" version ".tar.bz2"))
            (sha256
-            (base32 "0ny5w1agr9jaz5w3wyyxf1ygmzmd1sivaf97lcm4z4w6529520lz"))))
+            (base32 "0k0xnqmxi5lna034i2cnzvfzrykxmv4fbs1nkrc9sd2ma1igrmns"))))
        ("gettext" ,gettext-minimal)
        ("glib:bin" ,glib "bin")         ; for gdbus-codegen
        ("pkg-config" ,pkg-config)))
     (inputs
      `(("dbus" ,dbus)
+       ("gtk+" ,gtk+-2)
        ("qtbase" ,qtbase-5)
        ("qtmultimedia" ,qtmultimedia)
        ;; Plugin dependencies
@@ -248,9 +250,9 @@ 
        ("libcddb" ,libcddb)
        ("libcdio-paranoia" ,libcdio-paranoia)
        ("libcue" ,libcue)
-       ("libmodplug" ,libmodplug)
        ("libnotify" ,libnotify)
        ("libogg" ,libogg)
+       ("libopenmpt" ,libopenmpt)
        ("libsamplerate" ,libsamplerate)
        ("libsndfile" ,libsndfile)
        ("libvorbis" ,libvorbis)