diff mbox series

[bug#49792] gnu: Add r-ggh4x.

Message ID 20210731124851.3168-1-wz@freeshell.de
State Accepted
Headers show
Series [bug#49792] gnu: Add r-ggh4x. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Wiktor Żelazny July 31, 2021, 12:48 p.m. UTC
* gnu/packages/cran.scm (r-ggh4x): New variable.
---
 gnu/packages/cran.scm | 32 +++++++++++++++++++++++++++++++-
 1 file changed, 31 insertions(+), 1 deletion(-)


base-commit: 9f48f71398d7e95c496ecca6936e431811d3a1de

Comments

Simon Tournier Aug. 18, 2021, 2:03 p.m. UTC | #1
Hi,

CC Ricardo in case they miss it. ;-)

On Sat, 31 Jul 2021 at 14:48, Wiktor Żelazny <wz@freeshell.de> wrote:

> +    (synopsis "Hacks for ggplot2")

Instead of “Hacks”, I would write “Extension”.

> +    (description "This package provides a @code{ggplot2} extension that does a
> +variety of little helpful things.  The package extends @code{ggplot2} facets
> +through customisation, by setting individual scales per panel, resizing panels
> +and providing nested facets.  Also allows multiple colour and fill scales per
> +plot.  Also hosts a smaller collection of stats, geoms and axis guides.")

I would write something like that:

    (description "This package is a @code{ggplot2} extension.  It
    provides some utility functions that do not entirely fit within the
    grammar of graphics concept.  The package extends @code{ggpplots}
    facets through customisation, by setting individual scales per
    panel, resizing panels and providing nested facets.  It also allows
    multiple colour, fill scales per plot and hosts a smaller collection
    of stats, geoms and axis guides.")


All the best,
simon
Wiktor Żelazny Sept. 2, 2021, 4:43 p.m. UTC | #2
On Wed, Aug 18, 2021 at 04:03:39PM +0200, zimoun wrote:

> Instead of “Hacks”, I would write “Extension”.

> I would write something like that:

Hi simon,

Thanks for taking a look. I will resubmit the definition modified
according to your suggestions sometime later this month. It’s currently
holidays time for me.

Bye,

WŻ
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 25a6f71ca4..b2b86995ca 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -17,7 +17,7 @@ 
 ;;; Copyright © 2018 Marius Bakke <mbakke@fastmail.com>
 ;;; Copyright © 2018, 2019 Brett Gilio <brettg@gnu.org>
 ;;; Copyright © 2019 Nicolò Balzarotti <anothersms@gmail.com>
-;;; Copyright © 2019, 2020 Wiktor Żelazny <wzelazny@vurv.cz>
+;;; Copyright © 2019, 2020, 2021 Wiktor Żelazny <wzelazny@vurv.cz>
 ;;; Copyright © 2019 Arne Babenhauserheide <arne_bab@web.de>
 ;;; Copyright © 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2020 Todor Kondić <tk.code@protonmail.com>
@@ -29958,3 +29958,33 @@  applications.  The OpenCPU server runs either as a single-user development
 server within the interactive R session, or as a multi-user stack based on
 Apache2.")
     (license license:asl2.0)))
+
+(define-public r-ggh4x
+  (package
+    (name "r-ggh4x")
+    (version "0.1.2.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "ggh4x" version))
+       (sha256
+        (base32
+         "1a3aiyc1shw5hlf3m90dc528dsx4li6mqrh9g5i7s353yck226mj"))))
+    (properties `((upstream-name . "ggh4x")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-ggplot2" ,r-ggplot2)
+       ("r-gtable" ,r-gtable)
+       ("r-rlang" ,r-rlang)
+       ("r-scales" ,r-scales)
+       ("r-vctrs" ,r-vctrs)))
+    (native-inputs
+     `(("r-knitr" ,r-knitr)))
+    (home-page "https://github.com/teunbrand/ggh4x")
+    (synopsis "Hacks for ggplot2")
+    (description "This package provides a @code{ggplot2} extension that does a
+variety of little helpful things.  The package extends @code{ggplot2} facets
+through customisation, by setting individual scales per panel, resizing panels
+and providing nested facets.  Also allows multiple colour and fill scales per
+plot.  Also hosts a smaller collection of stats, geoms and axis guides.")
+    (license license:expat)))