diff mbox series

[bug#49762] gnu: graphviz-2.38: Fix build failure.

Message ID 20210728213223.31250-1-maximedevos@telenet.be
State Accepted
Headers show
Series [bug#49762] gnu: graphviz-2.38: Fix build failure. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

M July 28, 2021, 9:32 p.m. UTC
* gnu/packages/graphviz.scm
  (graphviz-2.38)[arguments]<#:phases>: Make this a G-exp.
---
 gnu/packages/graphviz.scm | 24 ++++++++++++------------
 1 file changed, 12 insertions(+), 12 deletions(-)

Comments

M July 28, 2021, 9:36 p.m. UTC | #1
Maxime Devos schreef op wo 28-07-2021 om 23:32 [+0200]:
> * gnu/packages/graphviz.scm
>   (graphviz-2.38)[arguments]<#:phases>: Make this a G-exp.

I forgot to mention this is for core-updates(-frozen?).
The subject should have been
  [PATCH core-updates] gnu: graphviz-2.38: Fix build failure.
(or [PATCH core-updates-frozen] gnu: graphviz-2.38: Fix build failure.?).

Greetings,
Maxime.
Mathieu Othacehe July 29, 2021, 7:34 a.m. UTC | #2
Hey,

> * gnu/packages/graphviz.scm
>   (graphviz-2.38)[arguments]<#:phases>: Make this a G-exp.

Pushed to core-updates & core-updates-frozen.

Thanks,

Mathieu
diff mbox series

Patch

diff --git a/gnu/packages/graphviz.scm b/gnu/packages/graphviz.scm
index 43eaecace4..eaddfb29c4 100644
--- a/gnu/packages/graphviz.scm
+++ b/gnu/packages/graphviz.scm
@@ -150,19 +150,19 @@  interfaces for other technical domains.")
       (arguments
        (substitute-keyword-arguments (package-arguments graphviz)
          ((#:phases phases)
-          `(modify-phases ,phases
-             (add-after 'unpack 'prepare-bootstrap
-               (lambda _
-                 (substitute* "autogen.sh"
-                   (("/bin/sh") (which "sh"))
-                   (("\\$GRAPHVIZ_VERSION_DATE") "0"))
-                 (setenv "CONFIG_SHELL" (which "sh"))
-                 (setenv "SHELL" (which "sh"))
+          #~(modify-phases #$phases
+              (add-after 'unpack 'prepare-bootstrap
+                (lambda _
+                  (substitute* "autogen.sh"
+                    (("/bin/sh") (which "sh"))
+                    (("\\$GRAPHVIZ_VERSION_DATE") "0"))
+                  (setenv "CONFIG_SHELL" (which "sh"))
+                  (setenv "SHELL" (which "sh"))
 
-                 (map make-file-writable (find-files "." ".*"))
-                 #t))
-             (replace 'bootstrap
-               (lambda _ (invoke (which "sh") "autogen.sh" "NOCONFIG") #t))))))
+                  (map make-file-writable (find-files "." ".*"))
+                  #t))
+              (replace 'bootstrap
+                (lambda _ (invoke (which "sh") "autogen.sh" "NOCONFIG") #t))))))
       (native-inputs
        `(("autoconf" ,autoconf)
          ("automake" ,automake)