diff mbox series

[bug#49736] gnu: Add emacs-nasm-mode.

Message ID 20210725214440.21002-1-noisytoot@disroot.org
State Accepted
Headers show
Series [bug#49736] gnu: Add emacs-nasm-mode. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Ron Nazarov July 25, 2021, 9:44 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-nasm-mode): New variable.
---
 gnu/packages/emacs-xyz.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

Comments

Nicolas Goaziou July 27, 2021, 5:43 p.m. UTC | #1
Hello,

Ron Nazarov via Guix-patches via <guix-patches@gnu.org> writes:

> * gnu/packages/emacs-xyz.scm (emacs-nasm-mode): New variable.

Thank you.

> +(define-public emacs-nasm-mode
> +  (package
> +    (name "emacs-nasm-mode")
> +    (version "20190410.342")
> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (string-append
> +             "https://melpa.org/packages/nasm-mode-"
> +             version
> +             ".el"))

Please use Github repository instead of MELPA.  The latter has a strange
versioning scheme, and source is not stable.

> +       (sha256
> +        (base32
> +         "10js4bdgqgvlhpk3mgq3rjglmkgkxchj1bny16bkl7glw5mqwl8c"))))
> +    (build-system emacs-build-system)
> +    (home-page "https://github.com/skeeto/nasm-mode")
> +    (synopsis "NASM x86 assembly major mode")
> +    (description
> +     "@code{nasm-mode} is a major mode for editing NASM x86 assembly programs.

I would write NASM mode is ...

> +It includes syntax highlighting, automatic indentation, and imenu integration.
> +Unlike Emacs' generic @code{asm-mode}, it understands NASM-specific syntax.")

ditto: ASM mode.

Could you send an updated patch?

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index a26a023a2b..83a59ca3a4 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -101,6 +101,7 @@ 
 ;;; Copyright © 2021 David Dashyan <mail@davie.li>
 ;;; Copyright © 2021 Dhruvin Gandhi <contact@dhruvin.dev>
 ;;; Copyright © 2021 Matthew James Kraai <kraai@ftbfs.org>
+;;; Copyright © 2021 Noisytoot <noisytoot@disroot.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -29037,3 +29038,26 @@  Believing} is a ruby gem to evaluate Ruby code, recording the results of each
 line.  This minor mode provides an easy way to run it from Emacs on the
 current region or entire buffer.")
       (license license:gpl3+))))
+
+(define-public emacs-nasm-mode
+  (package
+    (name "emacs-nasm-mode")
+    (version "20190410.342")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://melpa.org/packages/nasm-mode-"
+             version
+             ".el"))
+       (sha256
+        (base32
+         "10js4bdgqgvlhpk3mgq3rjglmkgkxchj1bny16bkl7glw5mqwl8c"))))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/skeeto/nasm-mode")
+    (synopsis "NASM x86 assembly major mode")
+    (description
+     "@code{nasm-mode} is a major mode for editing NASM x86 assembly programs.
+It includes syntax highlighting, automatic indentation, and imenu integration.
+Unlike Emacs' generic @code{asm-mode}, it understands NASM-specific syntax.")
+    (license license:unlicense)))