diff mbox series

[bug#49717] gnu: mesa-opencl-icd: Use absolute path for the library.

Message ID 20210724100127.8034-1-i.gankevich@spbu.ru
State Accepted
Headers show
Series [bug#49717] gnu: mesa-opencl-icd: Use absolute path for the library. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Ivan Gankevich July 24, 2021, 10:01 a.m. UTC
* gnu/packages/gl.scm (mesa-opencl-icd): Use absolute path for OpenCL
  platform library in "mesa.icd" file.  With this patch setting
  LD_LIBRARY_PATH=$LIBRARY_PATH is no longer needed to run OpenCL
  applications.
---
 gnu/packages/gl.scm | 24 ++++++++++++++++++++----
 1 file changed, 20 insertions(+), 4 deletions(-)

Comments

Guillaume Le Vaillant July 27, 2021, 4:40 p.m. UTC | #1
I added a copyright line and pushed the patch as
8cfd9ef831caff790c837eca87b1164801459108.
Thanks.
diff mbox series

Patch

diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index c14e7c0d53..f693efb36b 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -475,10 +475,26 @@  from software emulation to complete hardware acceleration for modern GPUs.")
   (package/inherit mesa-opencl
     (name "mesa-opencl-icd")
     (arguments
-     (substitute-keyword-arguments (package-arguments mesa)
-       ((#:configure-flags flags)
-        `(cons "-Dgallium-opencl=icd"
-               ,(delete "-Dgallium-opencl=standalone" flags)))))))
+      (substitute-keyword-arguments (package-arguments mesa)
+        ((#:configure-flags flags)
+         `(cons "-Dgallium-opencl=icd"
+                ,(delete "-Dgallium-opencl=standalone" flags)))
+        ((#:phases phases)
+         `(modify-phases ,phases
+            (add-after 'install 'mesa-icd-absolute-path
+              (lambda _
+                ;; Use absolute path for OpenCL platform library.
+                ;; Otherwise we would have to set LD_LIBRARY_PATH=LIBRARY_PATH
+                ;; for ICD in our applications to find OpenCL platform.
+                (use-modules (guix build utils)
+                             (ice-9 textual-ports))
+                (let* ((out (assoc-ref %outputs "out"))
+                       (mesa-icd (string-append out "/etc/OpenCL/vendors/mesa.icd"))
+                       (old-path (call-with-input-file mesa-icd get-string-all))
+                       (new-path (string-append out "/lib/" (string-trim-both old-path))))
+                  (if (file-exists? new-path)
+                    (call-with-output-file mesa-icd
+                      (lambda (port) (format port "~a\n" new-path)))))))))))))
 
 (define-public mesa-headers
   (package/inherit mesa