diff mbox series

[bug#49715] gnu: Add gmic-qt-gimp.

Message ID 20210724085155.21417-1-i.gankevich@spbu.ru
State Accepted
Headers show
Series [bug#49715] gnu: Add gmic-qt-gimp. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Ivan Gankevich July 24, 2021, 8:51 a.m. UTC
* gnu/packages/image-processing.scm (gmic-qt-gimp): New variable.
---
 gnu/packages/image-processing.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)

Comments

Vinicius Monego Oct. 22, 2021, 2:14 p.m. UTC | #1
Hi,

> * gnu/packages/image-processing.scm (gmic-qt-gimp): New variable.

I built and tested this patch and can confirm it works. A few nitpicks
that I have:

> +    (inputs
> +      ;; GIMP and its dependencies.
> +      `(("gimp" ,gimp)
> +        ("gdk-pixbuf" ,gdk-pixbuf)
> +        ("cairo" ,cairo)
> +        ("gegl" ,gegl)
> +        ,@(package-inputs gmic-qt)))

Should be one space below inputs. Also the labeled inputs should be
sorted alphabetically. See the gmic-qt package for instance.

> +    (arguments
> +      (substitute-keyword-arguments (package-arguments gmic-qt)
> +        ((#:configure-flags flags)
> +         '(list "-DGMIC_QT_HOST=gimp" "-DENABLE_DYNAMIC_LINKING=ON"
> +                (string-append "-DGMIC_LIB_PATH="
> +                               (assoc-ref %build-inputs "gmic")
> "/lib")))))

Should be one space below arguments (see gmic-qt-krita for instance).

If you're using Emacs, the indentation should be fixed automatically
with M-x indent-sexp or indent-region.

Vinicius
Leo Famulari Oct. 22, 2021, 8:32 p.m. UTC | #2
On Fri, Oct 22, 2021 at 02:14:15PM +0000, Vinicius Monego wrote:
> Hi,
> 
> > * gnu/packages/image-processing.scm (gmic-qt-gimp): New variable.
> 
> I built and tested this patch and can confirm it works. A few nitpicks
> that I have:
> 
> > +    (inputs
> > +      ;; GIMP and its dependencies.
> > +      `(("gimp" ,gimp)
> > +        ("gdk-pixbuf" ,gdk-pixbuf)
> > +        ("cairo" ,cairo)
> > +        ("gegl" ,gegl)
> > +        ,@(package-inputs gmic-qt)))
> 
> Should be one space below inputs. Also the labeled inputs should be
> sorted alphabetically. See the gmic-qt package for instance.
> 
> > +    (arguments
> > +      (substitute-keyword-arguments (package-arguments gmic-qt)
> > +        ((#:configure-flags flags)
> > +         '(list "-DGMIC_QT_HOST=gimp" "-DENABLE_DYNAMIC_LINKING=ON"
> > +                (string-append "-DGMIC_LIB_PATH="
> > +                               (assoc-ref %build-inputs "gmic")
> > "/lib")))))
> 
> Should be one space below arguments (see gmic-qt-krita for instance).
> 
> If you're using Emacs, the indentation should be fixed automatically
> with M-x indent-sexp or indent-region.

Thanks for the patch and the review, everybody!

I made the requested changes and pushed as
41492639e0223dc8fc1a357e1f9537577c055db7
diff mbox series

Patch

diff --git a/gnu/packages/image-processing.scm b/gnu/packages/image-processing.scm
index df77bef192..399ee55c87 100644
--- a/gnu/packages/image-processing.scm
+++ b/gnu/packages/image-processing.scm
@@ -17,6 +17,7 @@ 
 ;;; Copyright © 2021 Andy Tai <atai@atai.org>
 ;;; Copyright © 2021 Ekaitz Zarraga <ekaitz@elenq.tech>
 ;;; Copyright © 2021 Paul Garlick <pgarlick@tourbillion-technology.com>
+;;; Copyright © 2021 Ivan Gankevich <i.gankevich@spbu.ru>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -56,6 +57,7 @@ 
   #:use-module (gnu packages fontutils)
   #:use-module (gnu packages geo)
   #:use-module (gnu packages ghostscript)
+  #:use-module (gnu packages gimp)
   #:use-module (gnu packages gl)
   #:use-module (gnu packages glib)
   #:use-module (gnu packages gnome)
@@ -801,6 +803,25 @@  including 2D color images.")
                               (assoc-ref %build-inputs "gmic") "/lib")))))
     (synopsis "Krita plugin for the G'MIC image processing framework")))
 
+(define-public gmic-qt-gimp
+  (package
+    (inherit gmic-qt)
+    (name "gmic-qt-gimp")
+    (inputs
+      ;; GIMP and its dependencies.
+      `(("gimp" ,gimp)
+        ("gdk-pixbuf" ,gdk-pixbuf)
+        ("cairo" ,cairo)
+        ("gegl" ,gegl)
+        ,@(package-inputs gmic-qt)))
+    (arguments
+      (substitute-keyword-arguments (package-arguments gmic-qt)
+        ((#:configure-flags flags)
+         '(list "-DGMIC_QT_HOST=gimp" "-DENABLE_DYNAMIC_LINKING=ON"
+                (string-append "-DGMIC_LIB_PATH="
+                               (assoc-ref %build-inputs "gmic") "/lib")))))
+    (synopsis "GIMP plugin for the G'MIC image processing framework")))
+
 (define-public nip2
   (package
     (name "nip2")