diff mbox series

[bug#49672,3/9] gnu: Query membership in ‘supported-systems’ list with Nix identifier

Message ID 20210721010043.632012-3-bauermann@kolabnow.com
State New
Headers show
Series Target check fixes and cleanups | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Thiago Jung Bauermann July 21, 2021, 1 a.m. UTC
Packages’ ‘supported-systems’ list contains Nix system identifiers, while
‘%current-target-system’ contains a GNU triplet. We need to use
‘current-target-nix-system’ to query the list, which always returns a Nix
system identifier.

* gnu/packages/bootloaders.scm (grub)[inputs]: Use ‘current-target-nix-system’
to query membership in (package-supported-systems).
* gnu/packages/pciutils.scm (pciutils): Likewise.
---
 gnu/packages/bootloaders.scm | 9 +++------
 gnu/packages/pciutils.scm    | 3 +--
 2 files changed, 4 insertions(+), 8 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/bootloaders.scm b/gnu/packages/bootloaders.scm
index 742992a119b2..be51fb0c3de4 100644
--- a/gnu/packages/bootloaders.scm
+++ b/gnu/packages/bootloaders.scm
@@ -182,16 +182,14 @@ 
 
        ;; Depend on LVM2 for libdevmapper, used by 'grub-probe' and
        ;; 'grub-install' to recognize mapped devices (LUKS, etc.)
-       ,@(if (member (or (%current-target-system)
-                         (%current-system))
+       ,@(if (member (current-target-nix-system)
                      (package-supported-systems lvm2))
              `(("lvm2" ,lvm2))
              '())
 
        ;; Depend on mdadm, which is invoked by 'grub-probe' and 'grub-install'
        ;; to determine whether the root file system is RAID.
-       ,@(if (member (or (%current-target-system)
-                         (%current-system))
+       ,@(if (member (current-target-nix-system)
                      (package-supported-systems mdadm))
              `(("mdadm" ,mdadm))
              '())
@@ -202,8 +200,7 @@ 
 
        ;; Needed for ‘grub-mount’, the only reliable way to tell whether a given
        ;; file system will be readable by GRUB without rebooting.
-       ,@(if (member (or (%current-target-system)
-                         (%current-system))
+       ,@(if (member (current-target-nix-system)
                      (package-supported-systems fuse))
              `(("fuse" ,fuse))
              '())
diff --git a/gnu/packages/pciutils.scm b/gnu/packages/pciutils.scm
index d7d224b292f2..f2196c4e53ae 100644
--- a/gnu/packages/pciutils.scm
+++ b/gnu/packages/pciutils.scm
@@ -112,8 +112,7 @@ 
      `(("which" ,which)
        ("pkg-config" ,pkg-config)))
     (inputs
-     `(,@(if (member (or (%current-target-system)
-                         (%current-system))
+     `(,@(if (member (current-target-nix-system)
                      (package-supported-systems kmod))
              `(("kmod" ,kmod))
              '())