diff mbox series

[bug#49670] gnu: gnome-maps: Unregister from DBus when asked to.

Message ID 20210720223452.9471-1-leo.prikler@student.tugraz.at
State Accepted
Headers show
Series [bug#49670] gnu: gnome-maps: Unregister from DBus when asked to. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Leo Prikler July 20, 2021, 10:34 p.m. UTC
* gnu/packages/patches/gnome-maps-really-do-unregister.patch: New file.
* gnu/packages/geo.scm (gnome-maps)[patches]: Add it here...
* gnu/local.mk (dist_patch_DATA): ... and here.
---
I've opened a separate merge request upsteam [1], but since their CI is
currently failing, it will take some time for this patch to make it into a
release.

[1] https://gitlab.gnome.org/GNOME/gnome-maps/-/merge_requests/187

 gnu/local.mk                                        |  1 +
 gnu/packages/geo.scm                                |  5 ++++-
 .../patches/gnome-maps-really-do-unregister.patch   | 13 +++++++++++++
 3 files changed, 18 insertions(+), 1 deletion(-)
 create mode 100644 gnu/packages/patches/gnome-maps-really-do-unregister.patch

Comments

Ludovic Courtès July 21, 2021, 2:28 p.m. UTC | #1
Hi!

Leo Prikler <leo.prikler@student.tugraz.at> skribis:

> * gnu/packages/patches/gnome-maps-really-do-unregister.patch: New file.
> * gnu/packages/geo.scm (gnome-maps)[patches]: Add it here...
> * gnu/local.mk (dist_patch_DATA): ... and here.
> ---
> I've opened a separate merge request upsteam [1], but since their CI is
> currently failing, it will take some time for this patch to make it into a
> release.
>
> [1] https://gitlab.gnome.org/GNOME/gnome-maps/-/merge_requests/187

> +              (patches
> +               (search-patches
> +                "gnome-maps-really-do-unregister.patch"))))

This can all go on a single line.

> +++ b/gnu/packages/patches/gnome-maps-really-do-unregister.patch
> @@ -0,0 +1,13 @@
> +Index: gnome-maps-3.36.7/src/application.js

Could you add a line at the top of this patch saying what it does along
with a link to the merge request above?

Apart from that the two patches LGTM, especially if it allows me to use
gnome-maps again.  :-)

Thanks!

Ludo’.
Leo Prikler July 22, 2021, 8:31 a.m. UTC | #2
Am Mittwoch, den 21.07.2021, 16:28 +0200 schrieb Ludovic Courtès:
> Hi!
> 
> Leo Prikler <leo.prikler@student.tugraz.at> skribis:
> 
> > * gnu/packages/patches/gnome-maps-really-do-unregister.patch: New
> > file.
> > * gnu/packages/geo.scm (gnome-maps)[patches]: Add it here...
> > * gnu/local.mk (dist_patch_DATA): ... and here.
> > ---
> > I've opened a separate merge request upsteam [1], but since their
> > CI is
> > currently failing, it will take some time for this patch to make it
> > into a
> > release.
> > 
> > [1] https://gitlab.gnome.org/GNOME/gnome-maps/-/merge_requests/187
> > +              (patches
> > +               (search-patches
> > +                "gnome-maps-really-do-unregister.patch"))))
> 
> This can all go on a single line.
Forgot to count there, but thanks.

> > +++ b/gnu/packages/patches/gnome-maps-really-do-unregister.patch
> > @@ -0,0 +1,13 @@
> > +Index: gnome-maps-3.36.7/src/application.js
> 
> Could you add a line at the top of this patch saying what it does
> along with a link to the merge request above?
It turns out a similar fix already exists upstream [1], so if we decide
to backport that to 3.36 instead of bumping the package to 3.38, I
think we should pick the "official" one.

> Apart from that the two patches LGTM, especially if it allows me to
> use gnome-maps again.  :-)
Do "the two patches" refer to this one alone or also to the one bumping
the package to 3.38?  Again, I'm a little unsure what would be the
preferred solution here, as either patch adds additional code that
would probably need to be reverted by Raghav in their GNOME 40 work.

Regards,

[1] 
https://gitlab.gnome.org/GNOME/gnome-maps/-/commit/2e64cf6909dfca559fcaf54c470134ecc4d64e9a
Ludovic Courtès July 23, 2021, 9:29 a.m. UTC | #3
Hi Leo,

Leo Prikler <leo.prikler@student.tugraz.at> skribis:

> Am Mittwoch, den 21.07.2021, 16:28 +0200 schrieb Ludovic Courtès:

[...]

>> > +++ b/gnu/packages/patches/gnome-maps-really-do-unregister.patch
>> > @@ -0,0 +1,13 @@
>> > +Index: gnome-maps-3.36.7/src/application.js
>> 
>> Could you add a line at the top of this patch saying what it does
>> along with a link to the merge request above?
> It turns out a similar fix already exists upstream [1], so if we decide
> to backport that to 3.36 instead of bumping the package to 3.38, I
> think we should pick the "official" one.

Even better.

>> Apart from that the two patches LGTM, especially if it allows me to
>> use gnome-maps again.  :-)
> Do "the two patches" refer to this one alone or also to the one bumping
> the package to 3.38?

Both, but I hadn’t realized there’s was an exclusive choice.

> Again, I'm a little unsure what would be the preferred solution here,
> as either patch adds additional code that would probably need to be
> reverted by Raghav in their GNOME 40 work.

I don’t know, I think it’s good to have short-term fixes anyway and it’s
OK if they have to be undone when we eventually upgrade.  Your call!

Thanks,
Ludo’.
Leo Prikler July 23, 2021, 10:51 a.m. UTC | #4
Am Freitag, den 23.07.2021, 11:29 +0200 schrieb Ludovic Courtès:
> Hi Leo,
> 
> Leo Prikler <leo.prikler@student.tugraz.at> skribis:
> 
> > Am Mittwoch, den 21.07.2021, 16:28 +0200 schrieb Ludovic Courtès:
> 
> [...]
> 
> > > > +++ b/gnu/packages/patches/gnome-maps-really-do-
> > > > unregister.patch
> > > > @@ -0,0 +1,13 @@
> > > > +Index: gnome-maps-3.36.7/src/application.js
> > > 
> > > Could you add a line at the top of this patch saying what it does
> > > along with a link to the merge request above?
> > It turns out a similar fix already exists upstream [1], so if we
> > decide
> > to backport that to 3.36 instead of bumping the package to 3.38, I
> > think we should pick the "official" one.
> 
> Even better.
> 
> > > Apart from that the two patches LGTM, especially if it allows me
> > > to
> > > use gnome-maps again.  :-)
> > Do "the two patches" refer to this one alone or also to the one
> > bumping
> > the package to 3.38?
> 
> Both, but I hadn’t realized there’s was an exclusive choice.

Well, the exclusive choice comes from the fact that the patch we would
have to add to 3.36 is already present in 3.38.1+.  So bumping to a
sufficiently recent gnome-maps "voids" the patch in that it is already
applied.

> > Again, I'm a little unsure what would be the preferred solution
> > here,
> > as either patch adds additional code that would probably need to be
> > reverted by Raghav in their GNOME 40 work.
> 
> I don’t know, I think it’s good to have short-term fixes anyway and
> it’s
> OK if they have to be undone when we eventually upgrade.  Your call!

I went with bumping to 3.38.  While I hope the test suite doesn't break
in 40 the same way it does here, there is a slim chance the phase I've
added needs to be kept.

Thanks
diff mbox series

Patch

diff --git a/gnu/local.mk b/gnu/local.mk
index 9a3d8f6eca..0743daf0f7 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1155,6 +1155,7 @@  dist_patch_DATA =						\
   %D%/packages/patches/gmp-arm-asm-nothumb.patch		\
   %D%/packages/patches/gmp-faulty-test.patch			\
   %D%/packages/patches/gnash-fix-giflib-version.patch	        \
+  %D%/packages/patches/gnome-maps-really-do-unregister.patch			\
   %D%/packages/patches/gnome-shell-theme.patch			\
   %D%/packages/patches/gnome-shell-disable-test.patch		\
   %D%/packages/patches/gnome-shell-CVE-2020-17489.patch		\
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 37be78edbf..9bf6749dca 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -218,7 +218,10 @@  topology functions.")
                                   name "-" version ".tar.xz"))
               (sha256
                (base32
-                "09rgw8hq3ligap1zzjhx25q354ficpbiw1z9ramghhcqbpylsxdh"))))
+                "09rgw8hq3ligap1zzjhx25q354ficpbiw1z9ramghhcqbpylsxdh"))
+              (patches
+               (search-patches
+                "gnome-maps-really-do-unregister.patch"))))
     (build-system meson-build-system)
     (arguments
      `(#:glib-or-gtk? #t
diff --git a/gnu/packages/patches/gnome-maps-really-do-unregister.patch b/gnu/packages/patches/gnome-maps-really-do-unregister.patch
new file mode 100644
index 0000000000..3b201f363d
--- /dev/null
+++ b/gnu/packages/patches/gnome-maps-really-do-unregister.patch
@@ -0,0 +1,13 @@ 
+Index: gnome-maps-3.36.7/src/application.js
+===================================================================
+--- gnome-maps-3.36.7.orig/src/application.js
++++ gnome-maps-3.36.7/src/application.js
+@@ -277,7 +277,7 @@ var Application = GObject.registerClass(
+     }
+ 
+     vfunc_dbus_unregister(connection, path) {
+-        super.vfunc_dbus_register(connection, path);
++        super.vfunc_dbus_unregister(connection, path);
+     }
+ 
+     vfunc_activate() {