diff mbox series

[bug#49659,v2\,core-updates,v2] gnu: guile: Fix failing tests on i686-linux.

Message ID 20210720213417.5285-1-maximedevos@telenet.be
State Accepted
Headers show
Series [bug#49659,v2\,core-updates,v2] gnu: guile: Fix failing tests on i686-linux. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

M July 20, 2021, 9:34 p.m. UTC
i586-gnu might have the same issue.

* gnu/packages/guile.scm (guile-3.0)[arguments]<#:configure-flags>:
  Add "-fexcess-precision=standard" to CFLAGS when
  (target-x86-32?) is true.

Fixes: <https://issues.guix.gnu.org/49368>.
---
 gnu/packages/guile.scm | 19 ++++++++++++++-----
 1 file changed, 14 insertions(+), 5 deletions(-)

Comments

Ludovic Courtès July 21, 2021, 1:49 p.m. UTC | #1
Hi,

Maxime Devos <maximedevos@telenet.be> skribis:

> i586-gnu might have the same issue.
>
> * gnu/packages/guile.scm (guile-3.0)[arguments]<#:configure-flags>:
>   Add "-fexcess-precision=standard" to CFLAGS when
>   (target-x86-32?) is true.
>
> Fixes: <https://issues.guix.gnu.org/49368>.

I tweaked the commit log and pushed as
fccc0275091af10a46471c68df525d19f446af9e.

Looks like we should be able to move forward with this branch now,
thank you!

Ludo’.
Mathieu Othacehe July 21, 2021, 2:50 p.m. UTC | #2
Hey,

> I tweaked the commit log and pushed as
> fccc0275091af10a46471c68df525d19f446af9e.
>
> Looks like we should be able to move forward with this branch now,
> thank you!

Thanks for taking care of that Maxime & Ludo :). Should we create a
core-updates-frozen branch that Cuirass would build for the "all"
subset? I can take care of that if so.

Mathieu
Ludovic Courtès July 23, 2021, 9:07 a.m. UTC | #3
Hi,

Mathieu Othacehe <othacehe@gnu.org> skribis:

>> I tweaked the commit log and pushed as
>> fccc0275091af10a46471c68df525d19f446af9e.
>>
>> Looks like we should be able to move forward with this branch now,
>> thank you!
>
> Thanks for taking care of that Maxime & Ludo :). Should we create a
> core-updates-frozen branch that Cuirass would build for the "all"
> subset? I can take care of that if so.

There are “two last things” to check IMO:

  1. Make sure powerpc64le-linux is in a good state.  Can we get it
     built? (We discussed adding a worker on the OSUOSL machine but I
     think we eventually dropped the ball.)

  2. <https://issues.guix.gnu.org/49597> will trigger rebuilds.  I was
     waiting before applying it so we get several people looking into
     it; Maxime had valid criticism, I’m interested in hearing from
     others too.  :-)

Once we’re OK on these two fronts, let’s branch ‘core-updates-frozen’
and unleash our package-fixing superpowers!

Ludo’.
M July 23, 2021, 9:27 a.m. UTC | #4
Ludovic Courtès schreef op vr 23-07-2021 om 11:07 [+0200]:
> Hi,
> 
> Mathieu Othacehe <othacehe@gnu.org> skribis:
> 
> > > I tweaked the commit log and pushed as
> > > fccc0275091af10a46471c68df525d19f446af9e.
> > > 
> > > Looks like we should be able to move forward with this branch now,
> > > thank you!
> > 
> > Thanks for taking care of that Maxime & Ludo :). Should we create a
> > core-updates-frozen branch that Cuirass would build for the "all"
> > subset? I can take care of that if so.
> 
> There are “two last things” to check IMO: [...]

For --target=x86_64-w64-mingw32, the patch
<https://issues.guix.gnu.org/49694> is required,
to fix a build failure of x86_64-w64-mingw32-binutils.

Greetings,
Maxime.
Thiago Jung Bauermann July 25, 2021, 11:52 p.m. UTC | #5
Hello,

Em sexta-feira, 23 de julho de 2021, às 06:07:45 -03, Ludovic Courtès 
escreveu:
> Hi,
> 
> Mathieu Othacehe <othacehe@gnu.org> skribis:
> >> I tweaked the commit log and pushed as
> >> fccc0275091af10a46471c68df525d19f446af9e.
> >> 
> >> Looks like we should be able to move forward with this branch now,
> >> thank you!
> > 
> > Thanks for taking care of that Maxime & Ludo :). Should we create a
> > core-updates-frozen branch that Cuirass would build for the "all"
> > subset? I can take care of that if so.
> 
> There are “two last things” to check IMO:
> 
>   1. Make sure powerpc64le-linux is in a good state.  Can we get it
>      built? (We discussed adding a worker on the OSUOSL machine but I
>      think we eventually dropped the ball.)
> 
>   2. <https://issues.guix.gnu.org/49597> will trigger rebuilds.  I was
>      waiting before applying it so we get several people looking into
>      it; Maxime had valid criticism, I’m interested in hearing from
>      others too.  :-)
> 
> Once we’re OK on these two fronts, let’s branch ‘core-updates-frozen’
> and unleash our package-fixing superpowers!

Perhaps libdrm and Mesa could be updated before the freeze as suggested by 
John Kehayias¹?

Or could/should that be done on a branch apart from core-updates? Not sure 
if that’s what Ricardo’s suggestion about creating a new branch means.
diff mbox series

Patch

diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index d78c57e88c..86621e4ca0 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -16,6 +16,7 @@ 
 ;;; Copyright © 2018 Eric Bavier <bavier@member.fsf.org>
 ;;; Copyright © 2019 Taylan Kammer <taylan.kammer@gmail.com>
 ;;; Copyright © 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -316,11 +317,19 @@  without requiring the source code to be rewritten.")
     (arguments
      (substitute-keyword-arguments (package-arguments guile-2.2)
        ((#:configure-flags flags ''())
-        (let ((flags `(cons "--enable-mini-gmp" ,flags)))
-          ;; XXX: JIT-enabled Guile crashes in obscure ways on GNU/Hurd.
-          (if (hurd-target?)
-              `(cons "--disable-jit" ,flags)
-              flags)))
+        ;; XXX: JIT-enabled Guile crashes in obscure ways on GNU/Hurd.
+        `(cons* ,@(if (hurd-target?)
+                      '("--disable-jit")
+                      '())
+                ;; -fexcess-precision=standard is required when compiling for
+                ;; i686-linux, otherwise "numbers.test" will fail
+                ;; (see <https://issues.guix.gnu.org/49368> and
+                ;; <https://issues.guix.gnu.org/49659>).
+                ,@(if (target-x86-32?)
+                      '("CFLAGS=-g -O2 -fexcess-precision=standard")
+                      '())
+                "--enable-mini-gmp"
+                ,flags))
        ((#:phases phases)
         `(modify-phases ,phases
            (add-before 'check 'disable-stack-overflow-test