diff mbox series

[bug#49653] gnu: Fix broken links to Arch Linux git repositories

Message ID 20210720040201.533120-1-milkeymouse@meme.institute
State Accepted
Headers show
Series [bug#49653] gnu: Fix broken links to Arch Linux git repositories | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Milkey Mouse July 20, 2021, 4:02 a.m. UTC
* gnu/packages/crypto.scm (libsecp256k1): Update comment patch link.
* gnu/packages/engineering.scm (freehdl): Update patch link.
* gnu/packages/tex.scm (texlive-bin): Update arch-patch base URL.
---
Arch recently retired git.archlinux.org and now hosts SVN mirrors on
GitLab and GitHub. This caused builds of packages which downloaded
patches from git.archlinux.org to fail. This was mentioned on IRC a few
days ago and I encountered it myself when building texlive-bin without
substitutes. This commit points links to where the patches now live.

 gnu/packages/crypto.scm      | 2 +-
 gnu/packages/engineering.scm | 9 +++++----
 gnu/packages/tex.scm         | 6 +++---
 3 files changed, 9 insertions(+), 8 deletions(-)

Comments

Ludovic Courtès Aug. 4, 2021, 3:20 p.m. UTC | #1
Hi,

Milkey Mouse <milkeymouse@meme.institute> skribis:

> * gnu/packages/crypto.scm (libsecp256k1): Update comment patch link.
> * gnu/packages/engineering.scm (freehdl): Update patch link.
> * gnu/packages/tex.scm (texlive-bin): Update arch-patch base URL.
> ---
> Arch recently retired git.archlinux.org and now hosts SVN mirrors on
> GitLab and GitHub. This caused builds of packages which downloaded
> patches from git.archlinux.org to fail. This was mentioned on IRC a few
> days ago and I encountered it myself when building texlive-bin without
> substitutes. This commit points links to where the patches now live.

Good catch.  Applied, thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/crypto.scm b/gnu/packages/crypto.scm
index fe2cec045d..c545f47fcf 100644
--- a/gnu/packages/crypto.scm
+++ b/gnu/packages/crypto.scm
@@ -1118,7 +1118,7 @@  trivial to build for local use.  Portability is emphasized over performance.")
          ("automake" ,automake)
          ("libtool" ,libtool)))
       ;; WARNING: This package might need additional configure flags to run properly.
-      ;; See https://git.archlinux.org/svntogit/community.git/tree/trunk/PKGBUILD?h=packages/libsecp256k1.
+      ;; See https://github.com/archlinux/svntogit-community/blob/packages/libsecp256k1/trunk/PKGBUILD.
       (synopsis "C library for EC operations on curve secp256k1")
       (description
        "Optimized C library for EC operations on curve secp256k1.
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index fc932ddb28..33c124a2ea 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -1949,11 +1949,12 @@  parallel computing platforms.  It also supports serial execution.")
               (patches
                (list (origin
                        ;; Fix build with GCC 7.  Patch taken from Arch Linux:
-                       ;; https://git.archlinux.org/svntogit/community.git/tree/trunk?h=packages/freehdl
+                       ;; https://github.com/archlinux/svntogit-community/tree/packages/freehdl/trunk
                        (method url-fetch)
-                       (uri "https://git.archlinux.org/svntogit/community.git\
-/plain/trunk/build-fix.patch?h=packages/freehdl\
-&id=3bb90d64dfe6883e26083cd1fa96226d0d59175a")
+                       (uri (string-append "https://raw.githubusercontent.com"
+                                           "/archlinux/svntogit-community"
+                                           "/3bb90d64dfe6883e26083cd1fa96226d0d59175a"
+                                           "/trunk/build-fix.patch"))
                        (file-name "freehdl-c++-namespace.patch")
                        (sha256
                         (base32
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index b404ca8ff1..3013b1e8b5 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -252,9 +252,9 @@  files from LOCATIONS with expected checksum HASH.  CODE is not currently in use.
               (lambda (name revision hash)
                 (origin
                   (method url-fetch)
-                  (uri (string-append "https://git.archlinux.org/svntogit/packages.git"
-                                      "/plain/trunk/" name "?h=packages/texlive-bin"
-                                      "&id=" revision))
+                  (uri (string-append "https://raw.githubusercontent.com"
+                                      "/archlinux/svntogit-packages/" revision
+                                      "/repos/extra-x86_64/" name))
                   (file-name (string-append "texlive-bin-" name))
                   (sha256 (base32 hash)))))
              (arch-revision "49d7fe25e5ea63f136ebc20270c1d8fc9b00041c"))