diff mbox series

[bug#49633,v2,3/3] gnu: Add emacs-jupyter.

Message ID 20210719153316.249754-3-monego@posteo.net
State Accepted
Headers show
Series [bug#49633,v2,1/3] gnu: zeromq: Enable DRAFTs. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Vinicius Monego July 19, 2021, 3:33 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-jupyter): New variable.
---
No changes.

 gnu/packages/emacs-xyz.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index d3870ffa52..da27b5131c 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -16026,6 +16026,34 @@  Features:
 the pipeline, featuring the support for running @code{emacsclient}.")
     (license license:gpl3+)))
 
+(define-public emacs-jupyter
+  (package
+    (name "emacs-jupyter")
+    (version "0.8.2")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/nnicandro/emacs-jupyter")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1sr007wsl2y6wqpzkmv3inbpwhvgdcb2nmqzgfg7w1awapi2r13p"))))
+    (build-system emacs-build-system)
+    (propagated-inputs
+     `(("emacs-company" ,emacs-company) ;optional
+       ("emacs-markdown-mode" ,emacs-markdown-mode) ;optional
+       ("emacs-simple-httpd" ,emacs-simple-httpd)
+       ("emacs-websocket" ,emacs-websocket)
+       ("emacs-zmq" ,emacs-zmq)))
+    (home-page "https://github.com/nnicandro/emacs-jupyter")
+    (synopsis "Emacs interface to communicate with Jupyter kernels")
+    (description "This package provides an Emacs interface to communicate with
+Jupyter kernels.  It provides REPL and @code{org-mode} source code block
+frontends to Jupyter kernels and kernel interactions integrated with Emacs'
+built-in features.")
+    (license license:gpl3+)))
+
 (define-public emacs-hcl-mode
   (package
     (name "emacs-hcl-mode")