diff mbox series

[bug#49533] gnu: Add omins-lv2.

Message ID 20210712094506.6432-1-t_w_@freenet.de
State New
Headers show
Series [bug#49533] gnu: Add omins-lv2. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Thorsten Wilms July 12, 2021, 9:45 a.m. UTC
* gnu/packages/audio.scm (omins-lv2): New variable.
---
 gnu/packages/audio.scm | 38 +++++++++++++++++++++++++++++++++++++-
 1 file changed, 37 insertions(+), 1 deletion(-)

Comments

Sarah Morgensen July 22, 2021, 4:15 a.m. UTC | #1
Hello,

Thanks for the patch. Just a quick comment...

Thorsten Wilms <t_w_@freenet.de> writes:

> * gnu/packages/audio.scm (omins-lv2): New variable.
> ---
>  gnu/packages/audio.scm | 38 +++++++++++++++++++++++++++++++++++++-
>  1 file changed, 37 insertions(+), 1 deletion(-)
>
> diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
> index 3939d4bc7e..8eceb839ad 100644
> --- a/gnu/packages/audio.scm
> +++ b/gnu/packages/audio.scm
> @@ -15,7 +15,7 @@
>  ;;; Copyright © 2018 Clément Lassieur <clement@lassieur.org>
>  ;;; Copyright © 2018 Brett Gilio <brettg@gnu.org>
>  ;;; Copyright © 2018, 2019 Marius Bakke <mbakke@fastmail.com>
> -;;; Copyright © 2018 Thorsten Wilms <t_w_@freenet.de>
> +;;; Copyright © 2018, 2021 Thorsten Wilms <t_w_@freenet.de>
>  ;;; Copyright © 2018 Eric Bavier <bavier@member.fsf.org>
>  ;;; Copyright © 2018 Brendan Tildesley <mail@brendan.scot>
>  ;;; Copyright © 2019, 2021 Pierre Langlois <pierre.langlois@gmx.com>
> @@ -5410,3 +5410,39 @@ device.  There is support for mono and/or stereo and 8 or 16 bit samples.")
>       "MDA-LV2 is an LV2 port of the MDA plugins.  It includes effects and a few
>  instrument plugins.")
>      (license license:gpl3+)))
> +
> +(define-public omins-lv2
> +  (package
> +   (name "omins-lv2")
> +   ;; No release despite being perfectly usable. 0.0.0 seems to be the only
> +   ;; version the author ever specified:
> +   (version "0.0.0")
> +   (source
> +    (origin
> +     (method git-fetch)
> +     (uri
> +      (git-reference
> +       (url "https://git.drobilla.net/cgit.cgi/omins.lv2.git/")
> +       (commit "058f341053067b69a84d4081107fda5058290ff9")))
> +     (file-name (git-file-name name version))
> +     (sha256
> +      (base32 "01hnx4hhbz3ap3bw15s42q4q1mw1mhdjwygq4550wvjfg6k4ga8w"))))
> +   (build-system waf-build-system)
> +   (arguments
> +    `(#:tests? #f  ; There are no tests.
> +      #:configure-flags
> +      (list (string-append "--prefix="
> +			   (assoc-ref %outputs "out")))))

Setting --prefix shouldn't be necessary, as the build systems usually
add that themselves. (And yep, just tried building without it, and the
outputs are identical.)

> +   (inputs
> +    `(("lv2" ,lv2)))
> +   (native-inputs
> +    `(("pkg-config" ,pkg-config)))
> +   (native-search-paths
> +    (list (search-path-specification
> +           (variable "LV2_PATH")
> +           (files '("lib/lv2")))))
> +   (home-page "https://git.drobilla.net/cgit.cgi/omins.lv2.git/")
> +   (synopsis "LV2 audio plugins for modular synthesis")
> +   (description
> +    "Omins-lv2 is a small collection of LV2 audio plugins for modular synthesis.")
> +   (license (list license:gpl2+ license:gpl2+))))

--
Sarah
Ricardo Wurmus Feb. 25, 2024, 12:15 p.m. UTC | #2
I'm sorry for the long delay.

I adjusted the package definition and pushed to the master branch with
commit 386080366c642d887f9156059e4e894cd2d4e9b1.
diff mbox series

Patch

diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 3939d4bc7e..8eceb839ad 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -15,7 +15,7 @@ 
 ;;; Copyright © 2018 Clément Lassieur <clement@lassieur.org>
 ;;; Copyright © 2018 Brett Gilio <brettg@gnu.org>
 ;;; Copyright © 2018, 2019 Marius Bakke <mbakke@fastmail.com>
-;;; Copyright © 2018 Thorsten Wilms <t_w_@freenet.de>
+;;; Copyright © 2018, 2021 Thorsten Wilms <t_w_@freenet.de>
 ;;; Copyright © 2018 Eric Bavier <bavier@member.fsf.org>
 ;;; Copyright © 2018 Brendan Tildesley <mail@brendan.scot>
 ;;; Copyright © 2019, 2021 Pierre Langlois <pierre.langlois@gmx.com>
@@ -5410,3 +5410,39 @@  device.  There is support for mono and/or stereo and 8 or 16 bit samples.")
      "MDA-LV2 is an LV2 port of the MDA plugins.  It includes effects and a few
 instrument plugins.")
     (license license:gpl3+)))
+
+(define-public omins-lv2
+  (package
+   (name "omins-lv2")
+   ;; No release despite being perfectly usable. 0.0.0 seems to be the only
+   ;; version the author ever specified:
+   (version "0.0.0")
+   (source
+    (origin
+     (method git-fetch)
+     (uri
+      (git-reference
+       (url "https://git.drobilla.net/cgit.cgi/omins.lv2.git/")
+       (commit "058f341053067b69a84d4081107fda5058290ff9")))
+     (file-name (git-file-name name version))
+     (sha256
+      (base32 "01hnx4hhbz3ap3bw15s42q4q1mw1mhdjwygq4550wvjfg6k4ga8w"))))
+   (build-system waf-build-system)
+   (arguments
+    `(#:tests? #f  ; There are no tests.
+      #:configure-flags
+      (list (string-append "--prefix="
+			   (assoc-ref %outputs "out")))))
+   (inputs
+    `(("lv2" ,lv2)))
+   (native-inputs
+    `(("pkg-config" ,pkg-config)))
+   (native-search-paths
+    (list (search-path-specification
+           (variable "LV2_PATH")
+           (files '("lib/lv2")))))
+   (home-page "https://git.drobilla.net/cgit.cgi/omins.lv2.git/")
+   (synopsis "LV2 audio plugins for modular synthesis")
+   (description
+    "Omins-lv2 is a small collection of LV2 audio plugins for modular synthesis.")
+   (license (list license:gpl2+ license:gpl2+))))