diff mbox series

[bug#49494,4/7] gnu: Add go-golang-org-x-term.

Message ID 20210709161940.12759-4-arunisaac@systemreboot.net
State Accepted
Headers show
Series [bug#49494,1/7] gnu: Add go-github-com-davecgh-go-xdr. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Arun Isaac July 9, 2021, 4:19 p.m. UTC
* gnu/packages/golang.scm (go-golang-org-x-term): New variable.
---
 gnu/packages/golang.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 8eb93b9456..673d206713 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -8300,3 +8300,27 @@  function.  In addition to the pure-Go implementation, this package also
 contains AVX-512 and AVX2 routines (generated by avo) that greatly increase
 performance for large inputs and outputs.")
     (license license:expat)))
+
+(define-public go-golang-org-x-term
+  (package
+    (name "go-golang-org-x-term")
+    (version "0.0.0-20210615171337-6886f2dfbf5b")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://go.googlesource.com/term")
+             (commit (go-version->git-ref version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "0661w7dp2ak1k4ii90v6chw2x8a6g4sc5j0ba58qlplaj4k5l0xs"))))
+    (build-system go-build-system)
+    (arguments '(#:import-path "golang.org/x/term"))
+    (propagated-inputs
+     `(("go-golang-org-x-sys" ,go-golang-org-x-sys)))
+    (home-page "https://pkg.go.dev/golang.org/x/term")
+    (synopsis "Go terminal/console support")
+    (description "@code{term} provides support functions for dealing with
+terminals, as commonly found on Unix systems.")
+    (license license:bsd-3)))