diff mbox series

[bug#49472,core-updates] gnu: texlive-bin: Use ‘--with-banner-add’ configure option

Message ID 20210708221319.571089-1-bauermann@kolabnow.com
State Accepted
Headers show
Series [bug#49472,core-updates] gnu: texlive-bin: Use ‘--with-banner-add’ configure option | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Thiago Jung Bauermann July 8, 2021, 10:13 p.m. UTC
The “Building TeX Live” manual has a section about configure options for
distro builds¹. They mention this option:

    --with-banner-add=/SomeDistro

    This isn’t technically required, but is strongly recommended, so your
    build and your distro can be distinguished from others.

Therefore add it to texlive-bin. This is how it appears on LuaTeX, for
example (it also shows up in other engines’ banners):

    $ luatex
    This is LuaTeX, Version 1.13.0 (TeX Live 2021/GNU Guix)
    restricted system commands enabled.
    **

The other options mentioned in that section are already being used.

¹ http://www.tug.org/texlive/doc/tlbuild.html#Distro-builds

* gnu/packages/tex.scm (texlive-bin)[arguments]: Add ‘--with-banner-add’
option.
---
 gnu/packages/tex.scm | 1 +
 1 file changed, 1 insertion(+)

Hello,

This is something I saw on the TeX Live build manual after I sent the
TeX Live 2021 patches. I’m tracking it in a separate bug because it’s
orthogonal to whether the 2021 update is applied.

The patch applies cleanly both on core-updates and on top of the
TeX Live 2021 patches in bug 49408.

FWIW, Debian and Ubuntu also use this option:

$ luatex
This is LuaTeX, Version 1.12.0 (TeX Live 2020/Debian)
 restricted system commands enabled.
**


Thanks,
Thiago

Comments

Ludovic Courtès July 24, 2021, 2:17 p.m. UTC | #1
Hi,

Thiago Jung Bauermann <bauermann@kolabnow.com> skribis:

> The “Building TeX Live” manual has a section about configure options for
> distro builds¹. They mention this option:
>
>     --with-banner-add=/SomeDistro
>
>     This isn’t technically required, but is strongly recommended, so your
>     build and your distro can be distinguished from others.
>
> Therefore add it to texlive-bin. This is how it appears on LuaTeX, for
> example (it also shows up in other engines’ banners):
>
>     $ luatex
>     This is LuaTeX, Version 1.13.0 (TeX Live 2021/GNU Guix)
>     restricted system commands enabled.
>     **
>
> The other options mentioned in that section are already being used.
>
> ¹ http://www.tug.org/texlive/doc/tlbuild.html#Distro-builds
>
> * gnu/packages/tex.scm (texlive-bin)[arguments]: Add ‘--with-banner-add’
> option.

Applied, thanks!

Ludo’.
Thiago Jung Bauermann July 24, 2021, 10:21 p.m. UTC | #2
Hello,

Em sábado, 24 de julho de 2021, às 11:17:18 -03, Ludovic Courtès escreveu:
> Hi,
> 
> Thiago Jung Bauermann <bauermann@kolabnow.com> skribis:
> > The “Building TeX Live” manual has a section about configure options
> > for
> > 
> > distro builds¹. They mention this option:
> >     --with-banner-add=/SomeDistro
> >     
> >     This isn’t technically required, but is strongly recommended, so
> >     your
> >     build and your distro can be distinguished from others.
> > 
> > Therefore add it to texlive-bin. This is how it appears on LuaTeX, for
> > 
> > example (it also shows up in other engines’ banners):
> >     $ luatex
> >     This is LuaTeX, Version 1.13.0 (TeX Live 2021/GNU Guix)
> >     restricted system commands enabled.
> >     **
> > 
> > The other options mentioned in that section are already being used.
> > 
> > ¹ http://www.tug.org/texlive/doc/tlbuild.html#Distro-builds
> > 
> > * gnu/packages/tex.scm (texlive-bin)[arguments]: Add
> > ‘--with-banner-add’
> > option.
> 
> Applied, thanks!

Thank you!

I appreciate your attention even to minor patches such as this one.
diff mbox series

Patch

diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index e4144e00edbe..5ea1921dc2a5 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -317,6 +317,7 @@  files from LOCATIONS with expected checksum HASH.  CODE is not currently in use.
        '("--disable-static"
          "--disable-native-texlive-build"
          "--enable-shared"
+         "--with-banner-add=/GNU Guix"
          "--with-system-cairo"
          "--with-system-freetype2"
          "--with-system-gd"