diff mbox series

[bug#49470] gnu: Add python-beautysh.

Message ID 20210708205053.6985-1-jgart@dismail.de
State New
Headers show
Series [bug#49470] gnu: Add python-beautysh. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

jgart July 8, 2021, 8:50 p.m. UTC
* gnu/packages/python-xyz.scm (python-beautysh): New variable.
---
 gnu/packages/python-xyz.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 2bb33dbd63..bde6ba851a 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -357,6 +357,32 @@  features of the Python's built-in dict.")
 from a docstring rather than the other way around.")
    (license license:mpl2.0)))
 
+(define-public python-beautysh
+  (package
+    (name "python-beautysh")
+    (version "6.1.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "beautysh" version))
+        (sha256
+          (base32
+            "0i6mnxhl3v48fx4hnd2q03rxy3wg6v444kjjjrm61lvshz5llswn"))))
+    (build-system python-build-system)
+    ;; Pypi release does not include tests and github release does not include
+    ;; setup.py.
+    (arguments
+      `(#:tests? #f))
+    (propagated-inputs
+      `(("python-colorama" ,python-colorama)))
+    (home-page
+      "https://github.com/lovesegfault/beautysh")
+    (synopsis "Bash beautifier for the masses")
+    (description "@command{beautysh} beautifies bash scripts.  @command{beautysh}
+can be called from the command line or used as a module.  In tests with large
+Linux system Bash scripts, its error-free score was ~99%.")
+    (license license:expat)))
+
 (define-public python-cachetools
   (package
     (name "python-cachetools")