diff mbox series

[bug#49464,v2,3/3] gnu: python-yubikey-manager: Update to 4.0.3.

Message ID 20210708122320.23196-4-contact@dhruvin.dev
State New
Headers show
Series With updated copyright and lint suggestions. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Dhruvin Gandhi July 8, 2021, 12:23 p.m. UTC
* gnu/packages/security-token.scm (python-yubikey-manager): Update to 4.0.3.
---
 gnu/packages/security-token.scm | 13 ++++++++++---
 1 file changed, 10 insertions(+), 3 deletions(-)

Comments

Maxim Cournoyer Aug. 7, 2023, 6:11 p.m. UTC | #1
Hello,

Dhruvin Gandhi <contact@dhruvin.dev> writes:

> * gnu/packages/security-token.scm (python-yubikey-manager): Update to 4.0.3.
> ---
>  gnu/packages/security-token.scm | 13 ++++++++++---
>  1 file changed, 10 insertions(+), 3 deletions(-)
>
> diff --git a/gnu/packages/security-token.scm b/gnu/packages/security-token.scm
> index 5ee3cb83f0..9f5340c975 100644
> --- a/gnu/packages/security-token.scm
> +++ b/gnu/packages/security-token.scm
> @@ -660,7 +660,7 @@ implementing a Relying Party.")
>  (define-public python-yubikey-manager
>    (package
>      (name "python-yubikey-manager")
> -    (version "2.1.0")
> +    (version "4.0.3")
>      (source (origin
>                (method url-fetch)
>                (uri (string-append
> @@ -668,7 +668,12 @@ implementing a Relying Party.")
>                      "/yubikey-manager-" version ".tar.gz"))
>                (sha256
>                 (base32
> -                "11rsmcaj60k3y5m5gdhr2nbbz0w5dm3m04klyxz0fh5hnpcmr7fm"))))
> +                "1x36dlsp8mfcgyp50iz64cpg2hpbc9cg2qsf16kw0g7sp3ynzfx7"))
> +              (snippet
> +               #~(begin
> +                   ;; Remove unused platform code.
> +                   (delete-file "ykman/hid/macos.py")
> +                   (delete-file "ykman/hid/windows.py")))))
>      (build-system python-build-system)
>      (propagated-inputs
>       `(("python-six" ,python-six)
> @@ -684,7 +689,9 @@ implementing a Relying Party.")
>         ("libusb" ,libusb)))
>      (native-inputs
>       `(("swig" ,swig)
> -       ("python-mock" ,python-mock)))
> +       ("python-mock" ,python-mock)
> +       ("python-pytest" ,python-pytest)
> +       ("python-makefun" ,python-makefun)))
>      (home-page "https://developers.yubico.com/yubikey-manager/")
>      (synopsis "Command line tool and library for configuring a YubiKey")
>      (description

Sorry these were left lingering without review; it seems since
yubikey-manager has made it to 5.1.1 in master.

Thank you!
diff mbox series

Patch

diff --git a/gnu/packages/security-token.scm b/gnu/packages/security-token.scm
index 5ee3cb83f0..9f5340c975 100644
--- a/gnu/packages/security-token.scm
+++ b/gnu/packages/security-token.scm
@@ -660,7 +660,7 @@  implementing a Relying Party.")
 (define-public python-yubikey-manager
   (package
     (name "python-yubikey-manager")
-    (version "2.1.0")
+    (version "4.0.3")
     (source (origin
               (method url-fetch)
               (uri (string-append
@@ -668,7 +668,12 @@  implementing a Relying Party.")
                     "/yubikey-manager-" version ".tar.gz"))
               (sha256
                (base32
-                "11rsmcaj60k3y5m5gdhr2nbbz0w5dm3m04klyxz0fh5hnpcmr7fm"))))
+                "1x36dlsp8mfcgyp50iz64cpg2hpbc9cg2qsf16kw0g7sp3ynzfx7"))
+              (snippet
+               #~(begin
+                   ;; Remove unused platform code.
+                   (delete-file "ykman/hid/macos.py")
+                   (delete-file "ykman/hid/windows.py")))))
     (build-system python-build-system)
     (propagated-inputs
      `(("python-six" ,python-six)
@@ -684,7 +689,9 @@  implementing a Relying Party.")
        ("libusb" ,libusb)))
     (native-inputs
      `(("swig" ,swig)
-       ("python-mock" ,python-mock)))
+       ("python-mock" ,python-mock)
+       ("python-pytest" ,python-pytest)
+       ("python-makefun" ,python-makefun)))
     (home-page "https://developers.yubico.com/yubikey-manager/")
     (synopsis "Command line tool and library for configuring a YubiKey")
     (description