diff mbox series

[bug#49450] gnu: emacs-deadgrep: Add missing input.

Message ID 20210707235624.25962-1-kraai@ftbfs.org
State Accepted
Headers show
Series [bug#49450] gnu: emacs-deadgrep: Add missing input. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Matthew James Kraai July 7, 2021, 11:56 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-deadgrep)[inputs]: Add ripgrep.
[arguments]: Add configure phase to set deadgrep-executable to absolute path.
---
 gnu/packages/emacs-xyz.scm | 15 +++++++++++++++
 1 file changed, 15 insertions(+)

Comments

Nicolas Goaziou July 8, 2021, 7:33 a.m. UTC | #1
Hello,

Matthew James Kraai <kraai@ftbfs.org> writes:

> * gnu/packages/emacs-xyz.scm (emacs-deadgrep)[inputs]: Add ripgrep.
> [arguments]: Add configure phase to set deadgrep-executable to
> absolute path.

Thank you.

> +                 ;; .el is read-only in git.
> +                 (chmod "deadgrep.el" #o644)

I used `make-file-writable' function instead of chmod.

Applied. Thank you.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 9591a4e6e7..fd7f1b54d3 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -20802,10 +20802,25 @@  accept and reject GitHub pull requests.")
           (base32
            "1vjhrq02l8gvdn2haygzq7277hnhjchs9xrfpcnh76gqip200gx4"))))
       (build-system emacs-build-system)
+      (inputs `(("ripgrep" ,ripgrep)))
       (propagated-inputs
        `(("emacs-dash" ,emacs-dash)
          ("emacs-s" ,emacs-s)
          ("emacs-spinner" ,emacs-spinner)))
+      (arguments
+       `(#:phases
+         (modify-phases %standard-phases
+           (add-after 'unpack 'configure
+             (lambda* (#:key inputs #:allow-other-keys)
+               (let ((ripgrep (assoc-ref inputs "ripgrep")))
+                 ;; .el is read-only in git.
+                 (chmod "deadgrep.el" #o644)
+                 ;; Specify the absolute file names of rg so that everything
+                 ;; works out-of-the-box.
+                 (emacs-substitute-variables
+                     "deadgrep.el"
+                   ("deadgrep-executable"
+                    (string-append ripgrep "/bin/rg")))))))))
       (home-page "https://github.com/Wilfred/deadgrep")
       (synopsis "Frontend for @code{ripgrep}")
       (description "This package provides an Emacs interface for performing