diff mbox series

[bug#49454] gnu: add bibtool

Message ID 20210707072550.29298-1-i.gankevich@spbu.ru
State Accepted
Headers show
Series [bug#49454] gnu: add bibtool | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Ivan Gankevich July 7, 2021, 7:25 a.m. UTC
---
 gnu/packages/tex.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)

Comments

Nicolas Goaziou July 8, 2021, 10:24 p.m. UTC | #1
Hello,

Ivan Gankevich <i.gankevich@spbu.ru> writes:

> +(define-public bibtool

Thank you! I provided a proper commit message, and expounded
description. Nitpick: I also moved home-page before the synopsis, as it
is usually located there in our packages.

I eventually added a copyright line for you at the top of the "tex.scm"
file.

Regards,
Ivan Gankevich July 9, 2021, 6:20 a.m. UTC | #2
>Thank you! I provided a proper commit message, and expounded
>description. Nitpick: I also moved home-page before the synopsis, as it
>is usually located there in our packages.
>
>I eventually added a copyright line for you at the top of the "tex.scm"
>file.

Thank you, Nicolas!
diff mbox series

Patch

diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 086d6190dd..752965a0a3 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -8629,3 +8629,29 @@  constructs TeX accepts as arguments to its @code{\\number} primitive
 are valid as arguments for the macros.  The package may be used under
 LaTeX and plain TeX.")
     (license (license:fsf-free "file:/binhex.dtx"))))
+
+(define-public bibtool
+  (package
+    (name "bibtool")
+    (version "2.68")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/ge-ne/bibtool")
+               (commit (string-append
+                         "BibTool_"
+                         (string-map
+                           (lambda (c) (if (char=? c #\.) #\_ c))
+                           version)))))
+        (file-name (git-file-name name version))
+        (sha256 (base32 "0grnmqj8w5018nd7r6drnq2yvfhf22gj9i3rj8ilhzm7zmz3zn0g"))))
+    (build-system gnu-build-system)
+    (arguments
+      `(#:test-target "test"))
+    (native-inputs
+      `(("perl" ,perl)))
+    (synopsis "Tool for manipulating BibTeX data bases")
+    (description "Pretty print, sort, merge, select entries from BibTeX files.")
+    (home-page "http://www.gerd-neugebauer.de/software/TeX/BibTool/en/")
+    (license license:gpl2+)))