diff mbox series

[bug#49450] gnu: emacs-deadgrep: Add missing input.

Message ID 20210707031810.27321-1-kraai@ftbfs.org
State Accepted
Headers show
Series [bug#49450] gnu: emacs-deadgrep: Add missing input. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Matthew James Kraai July 7, 2021, 3:18 a.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-deadgrep)[propagated-inputs]: Add
ripgrep.
---
 gnu/packages/emacs-xyz.scm | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

Add ripgrep as propagated-input, as is done for emacs-ripgrep and emacs-rg.

Comments

Nicolas Goaziou July 7, 2021, 2:20 p.m. UTC | #1
Hello,

Matthew James Kraai <kraai@ftbfs.org> writes:

> * gnu/packages/emacs-xyz.scm (emacs-deadgrep)[propagated-inputs]: Add
> ripgrep.
> ---
>  gnu/packages/emacs-xyz.scm | 3 ++-
>  1 file changed, 2 insertions(+), 1 deletion(-)
>
> Add ripgrep as propagated-input, as is done for emacs-ripgrep and
> emacs-rg.

I think ripgrep should be an input.  Both emacs-ripgrep and emacs-rg
needs to be fixed, too.

Regards,
Matthew James Kraai July 7, 2021, 3:42 p.m. UTC | #2
Hi Nicolas,

I was trying to ensure that when emacs-deadgrep is installed, ripgrep is also installed.  The former doesn’t need the latter to build but does require it at runtime.  Isn’t propagated-inputs the right field for that?

Sent from my iPhone

> On Jul 7, 2021, at 7:20 AM, Nicolas Goaziou <mail@nicolasgoaziou.fr> wrote:
> 
> Hello,
> 
> Matthew James Kraai <kraai@ftbfs.org> writes:
> 
>> * gnu/packages/emacs-xyz.scm (emacs-deadgrep)[propagated-inputs]: Add
>> ripgrep.
>> ---
>> gnu/packages/emacs-xyz.scm | 3 ++-
>> 1 file changed, 2 insertions(+), 1 deletion(-)
>> 
>> Add ripgrep as propagated-input, as is done for emacs-ripgrep and
>> emacs-rg.
> 
> I think ripgrep should be an input.  Both emacs-ripgrep and emacs-rg
> needs to be fixed, too.
> 
> Regards,
> -- 
> Nicolas Goaziou
Nicolas Goaziou July 7, 2021, 3:53 p.m. UTC | #3
Matthew Kraai <kraai@ftbfs.org> writes:

> I was trying to ensure that when emacs-deadgrep is installed, ripgrep
> is also installed. The former doesn’t need the latter to build but
> does require it at runtime. Isn’t propagated-inputs the right field
> for that?

Inputs are also available at runtime, but do not clobber user's profile.
It's preferable to use them, when it's reasonably possible.

In this case, it means you just need to modify the Elisp source to make
sure code points to the right ripgrep executable in the store. See,
e.g., emacs-flycheck-grammalecte.
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 9591a4e6e7..029b20ee72 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -20805,7 +20805,8 @@  accept and reject GitHub pull requests.")
       (propagated-inputs
        `(("emacs-dash" ,emacs-dash)
          ("emacs-s" ,emacs-s)
-         ("emacs-spinner" ,emacs-spinner)))
+         ("emacs-spinner" ,emacs-spinner)
+         ("ripgrep" ,ripgrep)))
       (home-page "https://github.com/Wilfred/deadgrep")
       (synopsis "Frontend for @code{ripgrep}")
       (description "This package provides an Emacs interface for performing