diff mbox series

[bug#49446,4/4] gnu: shotcut: Update to 21.06.29.

Message ID 20210706183627.134904-4-monego@posteo.net
State Accepted
Headers show
Series Add MLT 7 and update Shotcut. | expand

Commit Message

Vinicius Monego July 6, 2021, 6:36 p.m. UTC
* gnu/packages/video.scm (shotcut): Update to 21.06.29.
[arguments]{#:phases}: Don't return #t.
[inputs]: Use MLT 7.
---
 gnu/packages/video.scm | 9 ++++-----
 1 file changed, 4 insertions(+), 5 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index ebe1847050..02bfc6c0b0 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -4644,7 +4644,7 @@  transitions, and effects and then export your film to many common formats.")
 (define-public shotcut
   (package
     (name "shotcut")
-    (version "21.03.21")
+    (version "21.06.29")
     (source
      (origin
        (method git-fetch)
@@ -4653,7 +4653,7 @@  transitions, and effects and then export your film to many common formats.")
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "0jb488vynn0vmq22z51bg4hb4617732nva9rg52lzl89v5n8gmsi"))))
+        (base32 "0384iv2129mpalia39x8mn5xlbgx9ip994700jzjjxdqfq23a9qm"))))
     (build-system qt-build-system)
     (arguments
      `(#:tests? #f ;there are no tests
@@ -4682,8 +4682,7 @@  transitions, and effects and then export your film to many common formats.")
                  `("FREI0R_PATH" ":" =
                    (,(string-append frei0r "/lib/frei0r-1/")))
                  `("MLT_PREFIX" ":" =
-                   (,(assoc-ref inputs "mlt")))))
-             #t)))))
+                   (,(assoc-ref inputs "mlt"))))))))))
     (native-inputs
      `(("pkg-config" ,pkg-config)
        ("python" ,python-wrapper)
@@ -4696,7 +4695,7 @@  transitions, and effects and then export your film to many common formats.")
        ("lame" ,lame)
        ("libvpx" ,libvpx)
        ("libx264" ,libx264)
-       ("mlt" ,mlt-6)
+       ("mlt" ,mlt)
        ("pulseaudio" ,pulseaudio)
        ("qtbase" ,qtbase-5)
        ("qtdeclarative" ,qtdeclarative)