diff mbox series

[bug#49338,6/8] gnu: Add python-sphinxcontrib-autoprogram.

Message ID 20210705072931.2271-6-hugo.lecomte@inria.fr
State Accepted
Headers show
Series None | expand

Commit Message

Hugo Lecomte July 5, 2021, 7:29 a.m. UTC
* gnu/packages/sphinx.scm (python-sphinxcontrib-autoprogram): New variable.
---
 gnu/packages/sphinx.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index 0ca217e921..14207470c2 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -812,3 +812,27 @@  has support for rich output such as images, Latex math and even javascript
 widgets, and it allows to enable thebelab for live code execution with minimal
 effort.")
     (license license:bsd-3)))
+
+(define-public python-sphinxcontrib-autoprogram
+  (package
+    (name "python-sphinxcontrib-autoprogram")
+    (version "0.1.7")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "sphinxcontrib-autoprogram" version))
+       (sha256
+        (base32
+         "06hzim0d3fd72kf30fyjbbm5n8ibyybic0kf62gm79qp50zjwr5w"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-six" ,python-six)))
+    (native-inputs
+     `(("python-sphinx" ,python-sphinx)))
+    (home-page "https://github.com/sphinx-contrib/autoprogram")
+    (synopsis "Documenting CLI programs")
+    (description
+     "This contrib extension, sphinxcontrib.autoprogram, provides an
+automated way to document CLI programs.  It scans argparse.ArgumentParser object,
+and then expands it into a set of .. program:: and .. option:: directives.")
+    (license license:bsd-2)))