diff mbox series

[bug#49329,v2,5/5] gnu: Add python-pygame-sdl2.

Message ID 20210703092842.32189-5-leo.prikler@student.tugraz.at
State Accepted
Headers show
Series [bug#49329,v2,1/5] gnu: python2-renpy: Drop unused Ren'py sources. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Leo Prikler July 3, 2021, 9:28 a.m. UTC
* gnu/packages/game-development.scm (python-pygame-sdl2): New variable.
Inherit package definition from previous python2-pygame-sdl2, with the
following additions:
[source]: Also drop “gen3” in snippet.
[arguments]: Drop #:python.
[native-inputs]: Use ‘python-cython’ instead of ‘python2-cython’.
(python2-pygame-sdl2): Define in terms of python-pygame-sdl2.
---
 gnu/packages/game-development.scm | 13 ++++++++-----
 1 file changed, 8 insertions(+), 5 deletions(-)

Comments

Christopher Marusich July 11, 2021, 4:44 a.m. UTC | #1
Leo Prikler <leo.prikler@student.tugraz.at> writes:

> * gnu/packages/game-development.scm (python-pygame-sdl2): New variable.
> Inherit package definition from previous python2-pygame-sdl2, with the
> following additions:

Actually, it inherits from python-pygame, right?

> [source]: Also drop “gen3” in snippet.
> [arguments]: Drop #:python.
> [native-inputs]: Use ‘python-cython’ instead of ‘python2-cython’.
> (python2-pygame-sdl2): Define in terms of python-pygame-sdl2.

LGTM.
Leo Prikler July 11, 2021, 7 a.m. UTC | #2
Am Samstag, den 10.07.2021, 21:44 -0700 schrieb Chris Marusich:
> Leo Prikler <leo.prikler@student.tugraz.at> writes:
> 
> > * gnu/packages/game-development.scm (python-pygame-sdl2): New
> > variable.
> > Inherit package definition from previous python2-pygame-sdl2, with
> > the
> > following additions:
> 
> Actually, it inherits from python-pygame, right?
"Inherit" as in "use the code that was originally written for python2-
pygame-sdl2".  Did the inherit field change with this patch?  If so, I
should reflect it in the commit message.

> > [source]: Also drop “gen3” in snippet.
> > [arguments]: Drop #:python.
> > [native-inputs]: Use ‘python-cython’ instead of ‘python2-cython’.
> > (python2-pygame-sdl2): Define in terms of python-pygame-sdl2.
> 
> LGTM.
>
Christopher Marusich July 15, 2021, 7:21 a.m. UTC | #3
Leo Prikler <leo.prikler@student.tugraz.at> writes:

> Am Samstag, den 10.07.2021, 21:44 -0700 schrieb Chris Marusich:
>> Leo Prikler <leo.prikler@student.tugraz.at> writes:
>> 
>> > * gnu/packages/game-development.scm (python-pygame-sdl2): New
>> > variable.
>> > Inherit package definition from previous python2-pygame-sdl2, with
>> > the
>> > following additions:
>> 
>> Actually, it inherits from python-pygame, right?
> "Inherit" as in "use the code that was originally written for python2-
> pygame-sdl2".  Did the inherit field change with this patch?  If so, I
> should reflect it in the commit message.

I see now what you mean.  It's fine.

Personally, I think the word "re-use" would have been clearer, since it
is not possible to confuse it with the "inherit" feature of package
records.
Leo Prikler July 15, 2021, 11:46 a.m. UTC | #4
Am Donnerstag, den 15.07.2021, 00:21 -0700 schrieb Chris Marusich:
> Leo Prikler <leo.prikler@student.tugraz.at> writes:
> 
> > Am Samstag, den 10.07.2021, 21:44 -0700 schrieb Chris Marusich:
> > > Leo Prikler <leo.prikler@student.tugraz.at> writes:
> > > 
> > > > * gnu/packages/game-development.scm (python-pygame-sdl2): New
> > > > variable.
> > > > Inherit package definition from previous python2-pygame-sdl2,
> > > > with
> > > > the
> > > > following additions:
> > > 
> > > Actually, it inherits from python-pygame, right?
> > "Inherit" as in "use the code that was originally written for
> > python2-
> > pygame-sdl2".  Did the inherit field change with this patch?  If
> > so, I
> > should reflect it in the commit message.
> 
> I see now what you mean.  It's fine.
> 
> Personally, I think the word "re-use" would have been clearer, since
> it
> is not possible to confuse it with the "inherit" feature of package
> records.
I've changed the commit message to say "reuse" and pushed this now.  
Thanks!
diff mbox series

Patch

diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 5d5fa5cf8b..e1593c0f82 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -1106,12 +1106,12 @@  to create fully featured games and multimedia programs in the python language.")
 (define-public python2-pygame
   (package-with-python2 python-pygame))
 
-(define-public python2-pygame-sdl2
+(define-public python-pygame-sdl2
   (let ((real-version "2.1.0")
         (renpy-version "7.4.6"))
     (package
-      (inherit python2-pygame)
-      (name "python2-pygame-sdl2")
+      (inherit python-pygame)
+      (name "python-pygame-sdl2")
       (version (string-append real-version "-for-renpy-" renpy-version))
       (source
        (origin
@@ -1124,12 +1124,12 @@  to create fully featured games and multimedia programs in the python language.")
           '(begin
              ;; drop generated sources
              (delete-file-recursively "gen")
+             (delete-file-recursively "gen3")
              (delete-file-recursively "gen-static")
              #t))))
       (build-system python-build-system)
       (arguments
        `(#:tests? #f                ; tests require pygame to be installed first
-         #:python ,python-2
          #:phases
          (modify-phases %standard-phases
            (add-after 'set-paths 'set-sdl-vars
@@ -1149,7 +1149,7 @@  to create fully featured games and multimedia programs in the python language.")
        `(("sdl-union"
           ,(sdl-union (list sdl2 sdl2-image sdl2-mixer sdl2-ttf)))))
       (native-inputs
-       `(("python2-cython" ,python2-cython)))
+       `(("python-cython" ,python-cython)))
       (home-page "https://www.renpy.org/")
       (synopsis "Reimplementation of the Pygame API using SDL2")
       (description "Pygame_SDL2 reimplements the Pygame API using SDL2,
@@ -1158,6 +1158,9 @@  While it aims to be used as a drop-in replacement, it appears to be
 developed mainly for Ren'py.")
       (license (list license:lgpl2.1 license:zlib)))))
 
+(define-public python2-pygame-sdl2
+  (package-with-python2 python-pygame-sdl2))
+
 (define-public python2-renpy
   (package
     (name "python2-renpy")