diff mbox series

[bug#49329,v2,3/5] gnu: python2-renpy: Correct inputs.

Message ID 20210703092842.32189-3-leo.prikler@student.tugraz.at
State Accepted
Headers show
Series [bug#49329,v2,1/5] gnu: python2-renpy: Drop unused Ren'py sources. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Leo Prikler July 3, 2021, 9:28 a.m. UTC
* gnu/packages/game-development.scm (python2-renpy)[#:phases]<fix-commands>:
Search for ‘xdg-open’ in inputs.
<set-build-vars>: Search for ‘cython’ in native-inputs.
[native-inputs]: Move ‘xdg-utils’ from here…
[inputs]: … to here.
---
 gnu/packages/game-development.scm | 16 +++++++++-------
 1 file changed, 9 insertions(+), 7 deletions(-)

Comments

Christopher Marusich July 11, 2021, 4:55 a.m. UTC | #1
Leo Prikler <leo.prikler@student.tugraz.at> writes:

> * gnu/packages/game-development.scm (python2-renpy)[#:phases]<fix-commands>:
> Search for ‘xdg-open’ in inputs.
> <set-build-vars>: Search for ‘cython’ in native-inputs.
> [native-inputs]: Move ‘xdg-utils’ from here…
> [inputs]: … to here.

LGTM.
diff mbox series

Patch

diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 9b231ad333..7c5d45c412 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -1186,10 +1186,11 @@  developed mainly for Ren'py.")
        #:phases
        (modify-phases %standard-phases
          (add-after 'unpack 'fix-commands
-           (lambda _
+           (lambda* (#:key inputs #:allow-other-keys)
              (substitute* "renpy/editor.py"
                (("xdg-open")
-                (which "xdg-open")))
+                (string-append (assoc-ref inputs "xdg-utils")
+                               "/bin/xdg-open")))
              #t))
          (add-after 'unpack 'fix-include-paths
            (lambda* (#:key inputs #:allow-other-keys)
@@ -1199,9 +1200,10 @@  developed mainly for Ren'py.")
                                "/include/fribidi")))
              #t))
          (add-after 'set-paths 'set-build-vars
-           (lambda* (#:key inputs #:allow-other-keys)
+           (lambda* (#:key inputs native-inputs #:allow-other-keys)
              (setenv "RENPY_CYTHON"
-                     (string-append (assoc-ref inputs "python2-cython")
+                     (string-append (assoc-ref (or native-inputs inputs)
+                                               "python2-cython")
                                     "/bin/cython"))
              (setenv "RENPY_DEPS_INSTALL" (string-join (map cdr inputs) ":"))
              #t))
@@ -1240,14 +1242,14 @@  developed mainly for Ren'py.")
        ("glew" ,glew)
        ("libpng" ,libpng)
        ("sdl-union"
-        ,(sdl-union (list sdl2 sdl2-image sdl2-mixer sdl2-ttf)))))
+        ,(sdl-union (list sdl2 sdl2-image sdl2-mixer sdl2-ttf)))
+       ("xdg-utils" ,xdg-utils)))
     (propagated-inputs
      `(("python2-future" ,python2-future)
        ("python2-pygame" ,python2-pygame-sdl2)))
     (native-inputs
      `(("gcc" ,gcc-8) ; for const variables as initializer elements
-       ("python2-cython" ,python2-cython)
-       ("xdg-utils" ,xdg-utils)))
+       ("python2-cython" ,python2-cython)))
     (home-page "https://www.renpy.org/")
     (synopsis "Ren'py python module")
     (description "This package contains the shared libraries and Python modules