diff mbox series

[bug#49319] gnu: po4a: Update to 0.63.

Message ID 20210701162820.3333798-1-eu@euandre.org
State Accepted
Headers show
Series [bug#49319] gnu: po4a: Update to 0.63. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

EuAndreh July 1, 2021, 4:28 p.m. UTC
* gnu/packages/gettext.scm (po4a): Update to 0.63.
---
I've sent a patch yesterday that fixes PER5LIB on the package build of
po4a [0], but this one is unrelated and can be applied independently.

[0]: https://issues.guix.gnu.org/49294

 gnu/packages/gettext.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Julien Lepiller July 1, 2021, 6:10 p.m. UTC | #1
Since po4a is a dependency of guix (for the translated manual), have you checked that this does not break anything by running "make as-derivation"?

Le 1 juillet 2021 12:28:20 GMT-04:00, EuAndreh via Guix-patches via <guix-patches@gnu.org> a écrit :
>* gnu/packages/gettext.scm (po4a): Update to 0.63.
>---
>I've sent a patch yesterday that fixes PER5LIB on the package build of
>po4a [0], but this one is unrelated and can be applied independently.
>
>[0]: https://issues.guix.gnu.org/49294
>
> gnu/packages/gettext.scm | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>
>diff --git a/gnu/packages/gettext.scm b/gnu/packages/gettext.scm
>index 21228694d7..82604ee9be 100644
>--- a/gnu/packages/gettext.scm
>+++ b/gnu/packages/gettext.scm
>@@ -225,14 +225,14 @@ from Markdown files.")
> (define-public po4a
>   (package
>     (name "po4a")
>-    (version "0.61")
>+    (version "0.63")
>     (source (origin
>               (method url-fetch)
>(uri (string-append
>"https://github.com/mquinson/po4a/releases/download/v"
>                                   version "/po4a-" version ".tar.gz"))
>               (sha256
>                (base32
>-               
>"1nw61dj7ymrsjps79vvfdzp549drwd51kyj598937zvyafq4r5b2"))))
>+               
>"1kmlfpdl1i1wrcdn0k1frh44fq10sfwswi3azvibli2lakpf66z2"))))
>     (build-system perl-build-system)
>     (arguments
>      `(#:phases
>-- 
>2.32.0
Julien Lepiller July 1, 2021, 11:34 p.m. UTC | #2
Le Thu, 01 Jul 2021 14:10:12 -0400,
Julien Lepiller <julien@lepiller.eu> a écrit :

> Since po4a is a dependency of guix (for the translated manual), have
> you checked that this does not break anything by running "make
> as-derivation"?
>

Pushed as a597ddea423801158eaae7166e1730b10d0280e6, thank you!

In the end, I was able to run "make as-derivation" myself to check
everything was good :)
EuAndreh July 1, 2021, 11:48 p.m. UTC | #3
(Now replying to all xD)

I did run the build command you suggested, and it ran successfully:

```
$ ./pre-inst-env make as-derivation
...
/gnu/store/vm1mgqd3131gf2snf6qddvfxmj395dls-guix-20210701.23
```
EuAndreh July 2, 2021, 12:01 a.m. UTC | #4
Thanks!
diff mbox series

Patch

diff --git a/gnu/packages/gettext.scm b/gnu/packages/gettext.scm
index 21228694d7..82604ee9be 100644
--- a/gnu/packages/gettext.scm
+++ b/gnu/packages/gettext.scm
@@ -225,14 +225,14 @@  from Markdown files.")
 (define-public po4a
   (package
     (name "po4a")
-    (version "0.61")
+    (version "0.63")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://github.com/mquinson/po4a/releases/download/v"
                                   version "/po4a-" version ".tar.gz"))
               (sha256
                (base32
-                "1nw61dj7ymrsjps79vvfdzp549drwd51kyj598937zvyafq4r5b2"))))
+                "1kmlfpdl1i1wrcdn0k1frh44fq10sfwswi3azvibli2lakpf66z2"))))
     (build-system perl-build-system)
     (arguments
      `(#:phases