diff mbox series

[bug#49303] gnu: Add python-cmaes.

Message ID 20210630214026.924365-1-monego@posteo.net
State Accepted
Headers show
Series [bug#49303] gnu: Add python-cmaes. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Vinicius Monego June 30, 2021, 9:40 p.m. UTC
* gnu/packages/machine-learning.scm (python-cmaes): New variable.
---
 gnu/packages/machine-learning.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)

Comments

Mathieu Othacehe July 8, 2021, 2:50 p.m. UTC | #1
Hey,

> * gnu/packages/machine-learning.scm (python-cmaes): New variable.

Pushed as 57a747e15a9071e7e41bb1871a8f2d1938b03889.

Thanks,

Mathieu
diff mbox series

Patch

diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 837ebbba67..504cabc11d 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -1012,6 +1012,31 @@  good at identifying feature interactions that are normally overlooked by
 standard feature selection algorithms.")
     (license license:expat)))
 
+(define-public python-cmaes
+  (package
+    (name "python-cmaes")
+    (version "0.8.2")
+    (source
+     (origin
+       (method git-fetch) ;no tests in PyPI
+       (uri (git-reference
+             (url "https://github.com/CyberAgent/cmaes")
+             (commit (string-append "v" version))))
+       (sha256
+        (base32 "1jyckaifir528dz6m95nvky8hvqmz5gz6dlp65baahhbca0danzb"))
+       (file-name (git-file-name name version))))
+    (build-system python-build-system)
+    (native-inputs
+     `(("python-setuptools" ,python-setuptools) ;build fails without this
+       ("python-wheel" ,python-wheel)))
+    (propagated-inputs
+     `(("python-numpy" ,python-numpy)))
+    (home-page "https://github.com/CyberAgent/cmaes")
+    (synopsis "CMA-ES implementation for Python")
+    (description "This package provides provides an implementation of the
+Covariance Matrix Adaptation Evolution Strategy (CMA-ES) for Python.")
+    (license license:expat)))
+
 (define-public python-autograd
   (let* ((commit "442205dfefe407beffb33550846434baa90c4de7")
          (revision "0")