diff mbox series

[bug#49210,v4,14/16] gnu: Add perl-mime-base64.

Message ID 20210630033538.15059-14-rg@raghavgururajan.name
State Accepted
Headers show
Series [bug#49210,v4,01/16] gnu: Add perl-exporter. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Raghav Gururajan June 30, 2021, 3:35 a.m. UTC
* gnu/packages/perl.scm (perl-mime-base64): New variable.
---
 gnu/packages/perl.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 90bbf8c72c..a51e9e31f6 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -6410,6 +6410,31 @@  follows LRU semantics, that is, the last n results, where n is specified as
 the argument to the CACHESIZE parameter, will be cached.")
     (license (package-license perl))))
 
+(define-public perl-mime-base64
+  (package
+    (name "perl-mime-base64")
+    (version "3.16")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://cpan/authors/id/C/CA/CAPOEIRAB/"
+                           "MIME-Base64-" version ".tar.gz"))
+       (sha256
+        (base32 "05v04kjaz2ya0zaj4m64gzxpfv4vgxhw5n5h12z373gbg9pkvxvp"))))
+    (build-system perl-build-system)
+    (propagated-inputs
+     `(("perl-exporter" ,perl-exporter)
+       ("perl-xsloader" ,perl-xsloader)))
+    (home-page "https://metacpan.org/dist/MIME-Base64")
+    (synopsis "Encoding and decoding of base64 strings")
+    (description "MIME::Base64 module provides functions to encode and decode
+strings into and from the base64 encoding specified in RFC 2045 - MIME
+(Multipurpose Internet Mail Extensions).  The base64 encoding is designed to
+represent arbitrary sequences of octets in a form that need not be humanly
+readable.  A 65-character subset ([A-Za-z0-9+/=]) of US-ASCII is used, enabling
+6 bits to be represented per printable character.")
+    (license (package-license perl))))
+
 (define-public perl-mime-charset
   (package
     (name "perl-mime-charset")