diff mbox series

[bug#49210,v3,10/16] gnu: Add perl-test-portability-files.

Message ID 20210630031753.14653-10-rg@raghavgururajan.name
State Accepted
Headers show
Series [bug#49210,v3,01/16] gnu: Add perl-exporter. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Raghav Gururajan June 30, 2021, 3:17 a.m. UTC
* gnu/packages/perl-check.scm (perl-test-portability-files): New variable.
---
 gnu/packages/perl-check.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/perl-check.scm b/gnu/packages/perl-check.scm
index a761ebffcf..87f233a3aa 100644
--- a/gnu/packages/perl-check.scm
+++ b/gnu/packages/perl-check.scm
@@ -1157,6 +1157,31 @@  Pod::Simple to do the heavy lifting.")
 checks for pod coverage of all appropriate files.")
     (license artistic2.0)))
 
+(define-public perl-test-portability-files
+  (package
+    (name "perl-test-portability-files")
+    (version "0.10")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://cpan/authors/id/A/AB/ABRAXXA/"
+                           "Test-Portability-Files-" version ".tar.gz"))
+       (sha256
+        (base32 "05hs80gljkd6mhb8zvilyk3pjqxp5samgnymam5v9h9d94rb9r08"))))
+    (build-system perl-build-system)
+    (native-inputs
+     `(("perl-test-simple" ,perl-test-simple)))
+    (propagated-inputs
+     `(("perl-pathtools" ,perl-pathtools)))
+    (home-page "https://metacpan.org/dist/Test-Portability-Files")
+    (synopsis "Check file names portability")
+    (description "Test::Portability::Files module is used to check the
+portability across operating systems of the names of the files present in the
+distribution of a module.  The tests use the advices given in 'Files and
+Filesystems' in perlport.  The author of a distribution can select which tests
+to execute.")
+    (license perl-license)))
+
 (define-public perl-test-requires
   (package
     (name "perl-test-requires")