diff mbox series

[bug#49235] gnu: Add oneko.

Message ID 20210626192049.20405-1-timotej.lazar@araneo.si
State Accepted
Headers show
Series [bug#49235] gnu: Add oneko. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Timotej Lazar June 26, 2021, 7:20 p.m. UTC
* gnu/packages/toys.scm (oneko): New variable.
---
This adds the oneko version of the original xneko toy. The license
statement seems to be at the end of README (not sure as I can’t read
Japanese), but Debian and FSF agree it’s in the public domain.

`guix lint` complains about a newer version, but the only differences
are a somewhat less broken build system and an additional bitmap of the
BSD daemon, which is trademarked. I opted for this version instead of
basically reverting all changes from the newer one.

Thanks!
Timotej

 gnu/packages/toys.scm | 50 ++++++++++++++++++++++++++++++++++++++++++-
 1 file changed, 49 insertions(+), 1 deletion(-)

Comments

Leo Prikler June 27, 2021, 12:45 p.m. UTC | #1
Am Samstag, den 26.06.2021, 21:20 +0200 schrieb Timotej Lazar:
> * gnu/packages/toys.scm (oneko): New variable.
> ---
> This adds the oneko version of the original xneko toy. The license
> statement seems to be at the end of README (not sure as I can’t read
> Japanese), but Debian and FSF agree it’s in the public domain.
基本的にPDSですが、バグ修正や機能拡張は(こっそりでもいいですから)私(kato@ntts.co.jp)に教えて下さいね。
バージョンアップもするつもりです。
With my limited Japanese knowledge, this roughly translates to:
"It's basically PDS[1], but if it's about bug fixes or enhancements[2],
please write tell me (kato@ntss.co.jp).  I also plan to do version
updates."

[1] probably means public domain software
[2] the bracket expression(こっそりでもいいですから)roughly translates to "because
it's also fine if you do it silently", basically meaning it's also fine
if you fix bugs/enhance the program without telling Kato.

Based on the above, I think both Debian and the FSF are correct in
assuming, that *the code* is public domain.

> `guix lint` complains about a newer version, but the only differences
> are a somewhat less broken build system and an additional bitmap of
> the
> BSD daemon, which is trademarked. I opted for this version instead of
> basically reverting all changes from the newer one.
This, however, seems to be an odd choice to me, particularly because
the "sakura" variant already adds characters that are owned by CLAMP.

『カードキャプターさくら』およびそのキャラクターは CLAMP の著作物です。
ただしそのキャラクターは同人誌等における利用が容認されています。 
CLAMP 学園電子分校(http://www.clamp.f-2.co.jp/)をご参照ください。

This roughly translates to

"Cardcaptor Sakura" and it's characters are owned by CLAMP.
However, it is acceptable to use those characters in Doujin[1] work.
Please see CLAMP 学園電子分校[2](http://www.clamp.f-2.co.jp/)

[1] Japanese media companies are generally lax when it comes to enforce
their IPs against fans of their work, i.e. against doujins.  A
comparable scenario exists in the BBC tacitly allowing Doctor Who
fanfiction.  However, this does not always make them compatible with
free software – ZUN, the creator of Touhou, for instance disallows
commercial reuse without his approval.
[2] It's a proper name, and I'm not attempting to translate it.

Since the site mentioned appears to be currently down, I'll have to do
a little deeper dive to see whether it's actually safe to keep the
Cardcaptor Sakura characters.  However, this does call into the
question whether we can really pin a version that is safe from all
those legally dangerous bits.  I think it is probably safer to use the
same version as Debian (i.e. the currently latest IIUC) and apply the
same patch as Debian here.

Regards,
Leo
> 
>  gnu/packages/toys.scm | 50
> ++++++++++++++++++++++++++++++++++++++++++-
>  1 file changed, 49 insertions(+), 1 deletion(-)
> 
> diff --git a/gnu/packages/toys.scm b/gnu/packages/toys.scm
> index bbd5753841..d396062fe1 100644
> --- a/gnu/packages/toys.scm
> +++ b/gnu/packages/toys.scm
> @@ -1,7 +1,7 @@
>  ;;; GNU Guix --- Functional package management for GNU
>  ;;; Copyright © 2017, 2018, 2020 Tobias Geerinckx-Rice <me@tobias.gr
> >
>  ;;; Copyright © 2019 Jesse Gibbons <jgibbons2357+guix@gmail.com>
> -;;; Copyright © 2019, 2020 Timotej Lazar <timotej.lazar@araneo.si>
> +;;; Copyright © 2019, 2020, 2021 Timotej Lazar <
> timotej.lazar@araneo.si>
>  ;;; Copyright © 2020 Efraim Flashner <efraim@flashner.co.il>
>  ;;; Copyright © 2021 Leo Famulari <leo@famulari.name>
>  ;;;
> @@ -36,6 +36,54 @@
>    #:use-module (guix packages)
>    #:use-module (guix utils))
>  
> +(define-public oneko
> +  (package
> +    (name "oneko")
> +    ;; Identical to version 1.2.sakura.5b but without the
> trademarked BSD daemon.
> +    (version "1.1b.sakura.5")
> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (string-append
> +             "http://www.daidouji.com/oneko/distfiles/oneko-"
> version ".tar.gz"))
> +       (sha256
> +        (base32
> "0dh5xr579clq0871pk6m7xfmsa24jk3idgx61k7skl37i40klaa3"))))
> +    (build-system gnu-build-system)
> +    (native-inputs
> +     `(("imake" ,imake)))
> +    (inputs
> +     `(("libx11" ,libx11)
> +       ("libxext" ,libxext)))
> +    (arguments
> +     `(#:tests? #f ; no tests
> +       #:phases
> +       (modify-phases %standard-phases
> +         (replace 'configure
> +           (lambda _
> +             (substitute* "Imakefile"
> +               ((" = /bin/") " = ") ; don’t use absolute paths for
> cp, rm and strip
> +               (("\\$\\(DESTDIR\\)/man") "$(DESTDIR)/share/man"))
> +             (invoke "xmkmf")
> +             (substitute* "Makefile"
> +               ;; Fix incorrectly generated compiler flags.
> +               (("(CDEBUGFLAGS = ).*" _ front) (string-append front
> "-O2\n")))
> +             #t))
> +         (replace 'install
> +           (lambda* (#:key outputs #:allow-other-keys)
> +             (let* ((out (assoc-ref outputs "out"))
> +                    (doc (string-append out "/share/doc/" ,name)))
> +               (mkdir-p (string-append out "/bin"))
> +               (mkdir-p (string-append out "/share/man/man1"))
> +               (invoke "make" (string-append "DESTDIR=" out)
> "install")
> +               (for-each (lambda (file) (install-file file doc))
> +                         (find-files "." "README.*")))
> +             #t)))))
> +    (home-page "http://www.daidouji.com/oneko/")
> +    (synopsis "Cute cat chasing your mouse pointer")
> +    (description "Displays a cat or another animated character that
> chases the
> +mouse pointer around the screen while you work.")
> +    (license license:public-domain))) ; see 
> https://directory.fsf.org/wiki/Oneko
> +
>  (define-public sl
>    (package
>      (name "sl")
Timotej Lazar June 27, 2021, 1:40 p.m. UTC | #2
Leo Prikler <leo.prikler@student.tugraz.at> [2021-06-27 14:45:45+0200]:
> This roughly translates to
>
> "Cardcaptor Sakura" and it's characters are owned by CLAMP.
> However, it is acceptable to use those characters in Doujin[1] work.
> Please see CLAMP 学園電子分校[2](http://www.clamp.f-2.co.jp/)

Seems that Debian’s analysis, which was my primary source, is somewhat
lacking. It would probably be safest to remove all characters except the
original neko, tora and dog options. I can send a new package using the
latest version with these characters removed.

Thanks for taking the time to investigate this!
Leo Prikler June 27, 2021, 1:55 p.m. UTC | #3
Am Sonntag, den 27.06.2021, 15:40 +0200 schrieb Timotej Lazar:
> Leo Prikler <leo.prikler@student.tugraz.at> [2021-06-27
> 14:45:45+0200]:
> > This roughly translates to
> > 
> > "Cardcaptor Sakura" and it's characters are owned by CLAMP.
> > However, it is acceptable to use those characters in Doujin[1]
> > work.
> > Please see CLAMP 学園電子分校[2](http://www.clamp.f-2.co.jp/)
> 
> Seems that Debian’s analysis, which was my primary source, is
> somewhat
> lacking. It would probably be safest to remove all characters except
> the
> original neko, tora and dog options. I can send a new package using
> the
> latest version with these characters removed.
Upon further investigation, this page appears to have been dead for ~20
years.  The newer CLAMP homepage does not appear to mention doujins at
all and trying to search for a policy of theirs will only yield
unrelated results.

In other words, yeah, keeping only the original neko, tora and dog is
the safest bet here.  Please don't forget to also have a look at the
cursors.  From what I can see only the mouse and the bone should be
fine as they relate to neko and tora or dog respectively.

Regards,
Leo
Timotej Lazar June 27, 2021, 5:51 p.m. UTC | #4
Leo Prikler <leo.prikler@student.tugraz.at> [2021-06-27 15:55:17+0200]:
> In other words, yeah, keeping only the original neko, tora and dog is
> the safest bet here.  Please don't forget to also have a look at the
> cursors.  From what I can see only the mouse and the bone should be
> fine as they relate to neko and tora or dog respectively.

Good catch! I’ve sent a new patch which removes these bitmaps and
options, and also adds the Japanese manpage.

Thanks,
Timotej
Leo Prikler June 27, 2021, 6:24 p.m. UTC | #5
Am Sonntag, den 27.06.2021, 19:51 +0200 schrieb Timotej Lazar:
> Leo Prikler <leo.prikler@student.tugraz.at> [2021-06-27
> 15:55:17+0200]:
> > In other words, yeah, keeping only the original neko, tora and dog
> > is
> > the safest bet here.  Please don't forget to also have a look at
> > the
> > cursors.  From what I can see only the mouse and the bone should be
> > fine as they relate to neko and tora or dog respectively.
> 
> Good catch! I’ve sent a new patch which removes these bitmaps and
> options, and also adds the Japanese manpage.
Is man/$LANG/man the way this should be structured?

For the patch, I think that it deserves a better name + comment.  The
copyright in those cases is not unclear – it is very clear who owns
those bitmaps, and in at least one case it's further clear that the
owner doesn't want others to reuse them.  W.r.t. the name, I don't
think we should shorten references to "refs".  Find a name, that fits
into a line better without the use of abbrevs.

The snippet should probably also remove the .include files, which at
least seem referenced in the code.

Don't forget to add me through --cc when sending mail with git-email to
make sure I receive the updated version :)

Regards,
Leo
Timotej Lazar June 27, 2021, 7:06 p.m. UTC | #6
Leo Prikler <leo.prikler@student.tugraz.at> [2021-06-27 20:24:04+0200]:
> Is man/$LANG/man the way this should be structured?

I followed the pattern for existing manpages in my profile. `man -L ja
oneko` also returns the correct page. On a related note, would it be a
good idea to change the encoding from ISO-2022-JP to utf-8? `iconv`
produces a file that at least looks correct.

> For the patch, I think that it deserves a better name + comment.  The
> copyright in those cases is not unclear – it is very clear who owns
> those bitmaps, and in at least one case it's further clear that the
> owner doesn't want others to reuse them.

I am not sure if the copyright actually covers *all* depictions of the
BSD daemon (and others), or just the (variatons of) the original image.
But I’ll reword the comment to say “nonfree” instead.

> The snippet should probably also remove the .include files, which at
> least seem referenced in the code.

Those includes are patched out. Just in case I’ll change the snippet to
remove whole directories instead of just the *xbm files.

Thanks,
Timotej
Leo Prikler June 27, 2021, 7:24 p.m. UTC | #7
Am Sonntag, den 27.06.2021, 21:06 +0200 schrieb Timotej Lazar:
> Leo Prikler <leo.prikler@student.tugraz.at> [2021-06-27
> 20:24:04+0200]:
> > Is man/$LANG/man the way this should be structured?
> 
> I followed the pattern for existing manpages in my profile. `man -L
> ja
> oneko` also returns the correct page. On a related note, would it be
> a
> good idea to change the encoding from ISO-2022-JP to utf-8? `iconv`
> produces a file that at least looks correct.
"In that case go on" to the former and "yes" to the latter.

> > For the patch, I think that it deserves a better name +
> > comment.  The
> > copyright in those cases is not unclear – it is very clear who owns
> > those bitmaps, and in at least one case it's further clear that the
> > owner doesn't want others to reuse them.
> 
> I am not sure if the copyright actually covers *all* depictions of
> the
> BSD daemon (and others), or just the (variatons of) the original
> image.
> But I’ll reword the comment to say “nonfree” instead.
I think the Debian patch says it best in that there might be copyright
issues.

> > The snippet should probably also remove the .include files, which
> > at
> > least seem referenced in the code.
> 
> Those includes are patched out. Just in case I’ll change the snippet
> to
> remove whole directories instead of just the *xbm files.
To be fair, I only looked at the snippet, not what it produced, so it
might actually be that it already did the correct thing.  Are there
directory, which are matched by .*\\.xbm?

Regards,
Leo
Timotej Lazar June 27, 2021, 7:45 p.m. UTC | #8
Leo Prikler <leo.prikler@student.tugraz.at> [2021-06-27 21:24:00+0200]:
> I think the Debian patch says it best in that there might be copyright
> issues.

OK, I’ll copy / adjust that one then. :)

> To be fair, I only looked at the snippet, not what it produced, so it
> might actually be that it already did the correct thing.  Are there
> directory, which are matched by .*\\.xbm?

The snippet only deletes the *xbm files. There is also (for instance)
bsd.include that #includes the relevant bitmaps and is in turn #included
by the main source file. The latter #include statements are removed by
the patch.

I didn’t delete bsd.include (and others) in the snippet since they don’t
have copyright issues and it would make the snippet a bit messier. A
COPYRIGHT file for the BSD daemon also remains. If that is problematic,
I can adjust the snippet to also delete these files. In any case, none
of them gets copied to the output.
Leo Prikler June 27, 2021, 7:50 p.m. UTC | #9
Am Sonntag, den 27.06.2021, 21:45 +0200 schrieb Timotej Lazar:
> Leo Prikler <leo.prikler@student.tugraz.at> [2021-06-27
> 21:24:00+0200]:
> > I think the Debian patch says it best in that there might be
> > copyright
> > issues.
> 
> OK, I’ll copy / adjust that one then. :)
> 
> > To be fair, I only looked at the snippet, not what it produced, so
> > it
> > might actually be that it already did the correct thing.  Are there
> > directory, which are matched by .*\\.xbm?
> 
> The snippet only deletes the *xbm files. There is also (for instance)
> bsd.include that #includes the relevant bitmaps and is in turn
> #included
> by the main source file. The latter #include statements are removed
> by
> the patch.
That is indeed a good way of splitting this up, but the mentioned files
would still need to be deleted (see below).

> I didn’t delete bsd.include (and others) in the snippet since they
> don’t
> have copyright issues and it would make the snippet a bit messier. A
> COPYRIGHT file for the BSD daemon also remains. If that is
> problematic,
> I can adjust the snippet to also delete these files. In any case,
> none
> of them gets copied to the output.
It's not just about the output, we're trying to keep `guix build -S`
clean as well.  I'm not sure about the copyright issues of these source
files -- in any case they only serve to enable the legally questionable
portions of the program, so in my opinion it's better to drop them.
diff mbox series

Patch

diff --git a/gnu/packages/toys.scm b/gnu/packages/toys.scm
index bbd5753841..d396062fe1 100644
--- a/gnu/packages/toys.scm
+++ b/gnu/packages/toys.scm
@@ -1,7 +1,7 @@ 
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2017, 2018, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2019 Jesse Gibbons <jgibbons2357+guix@gmail.com>
-;;; Copyright © 2019, 2020 Timotej Lazar <timotej.lazar@araneo.si>
+;;; Copyright © 2019, 2020, 2021 Timotej Lazar <timotej.lazar@araneo.si>
 ;;; Copyright © 2020 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2021 Leo Famulari <leo@famulari.name>
 ;;;
@@ -36,6 +36,54 @@ 
   #:use-module (guix packages)
   #:use-module (guix utils))
 
+(define-public oneko
+  (package
+    (name "oneko")
+    ;; Identical to version 1.2.sakura.5b but without the trademarked BSD daemon.
+    (version "1.1b.sakura.5")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "http://www.daidouji.com/oneko/distfiles/oneko-" version ".tar.gz"))
+       (sha256
+        (base32 "0dh5xr579clq0871pk6m7xfmsa24jk3idgx61k7skl37i40klaa3"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     `(("imake" ,imake)))
+    (inputs
+     `(("libx11" ,libx11)
+       ("libxext" ,libxext)))
+    (arguments
+     `(#:tests? #f ; no tests
+       #:phases
+       (modify-phases %standard-phases
+         (replace 'configure
+           (lambda _
+             (substitute* "Imakefile"
+               ((" = /bin/") " = ") ; don’t use absolute paths for cp, rm and strip
+               (("\\$\\(DESTDIR\\)/man") "$(DESTDIR)/share/man"))
+             (invoke "xmkmf")
+             (substitute* "Makefile"
+               ;; Fix incorrectly generated compiler flags.
+               (("(CDEBUGFLAGS = ).*" _ front) (string-append front "-O2\n")))
+             #t))
+         (replace 'install
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let* ((out (assoc-ref outputs "out"))
+                    (doc (string-append out "/share/doc/" ,name)))
+               (mkdir-p (string-append out "/bin"))
+               (mkdir-p (string-append out "/share/man/man1"))
+               (invoke "make" (string-append "DESTDIR=" out) "install")
+               (for-each (lambda (file) (install-file file doc))
+                         (find-files "." "README.*")))
+             #t)))))
+    (home-page "http://www.daidouji.com/oneko/")
+    (synopsis "Cute cat chasing your mouse pointer")
+    (description "Displays a cat or another animated character that chases the
+mouse pointer around the screen while you work.")
+    (license license:public-domain))) ; see https://directory.fsf.org/wiki/Oneko
+
 (define-public sl
   (package
     (name "sl")