diff mbox series

[bug#49188,1/1] gnu: password-store: Fix passmenu paths substitution

Message ID 20210623152959.31046-1-mail@davie.li
State Accepted
Headers show
Series Fixing passmenu (password-store) command substitutions | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

David Dashyan June 23, 2021, 3:29 p.m. UTC
* gnu/packages/password-utils.scm (password-store)
[arguments]: Fix dmenu and xdotool path substitution in patch-passmenu-path
phase.
---
 gnu/packages/password-utils.scm | 15 +++++++++++----
 1 file changed, 11 insertions(+), 4 deletions(-)

Comments

Efraim Flashner July 13, 2021, 1:08 p.m. UTC | #1
Thanks. Patch pushed.
diff mbox series

Patch

diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index 9c8912c5e8..460193c72d 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -31,6 +31,7 @@ 
 ;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
 ;;; Copyright © 2021 Stefan Reichör <stefan@xsteve.at>
 ;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
+;;; Copyright © 2021 David Dashyan <mail@davie.li>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -517,12 +518,18 @@  any X11 window.")
                                  "}\"\n"))))
              #t))
          (add-before 'install 'patch-passmenu-path
+           ;; FIXME Wayland support requires ydotool and dmenu-wl packages
+           ;; We are ignoring part of the script that gets executed if
+           ;; WAYLAND_DISPLAY env variable is set, leaving dmenu-wl and ydotool
+           ;; commands as is.
            (lambda* (#:key inputs #:allow-other-keys)
              (substitute* "contrib/dmenu/passmenu"
-               (("dmenu") (string-append (assoc-ref inputs "dmenu")
-                                         "/bin/dmenu"))
-               (("xdotool") (string-append (assoc-ref inputs "xdotool")
-                                           "/bin/xdotool")))
+               (("dmenu=dmenu\n") (string-append "dmenu="
+                                                 (assoc-ref inputs "dmenu")
+                                                 "/bin/dmenu\n"))
+               (("xdotool=\"xdotool") (string-append "xdotool=\""
+                                                     (assoc-ref inputs "xdotool")
+                                                     "/bin/xdotool")))
              #t))
          (add-after 'install 'install-passmenu
            (lambda* (#:key outputs #:allow-other-keys)