diff mbox series

[bug#49170] New package: python-fire

Message ID 20210622133326.346547-1-dani.behzi@ubuntu.com
State Accepted
Headers show
Series [bug#49170] New package: python-fire | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Danial Behzadi June 22, 2021, 1:33 p.m. UTC
---
 gnu/packages/python-xyz.scm | 37 +++++++++++++++++++++++++++++++++++++
 1 file changed, 37 insertions(+)

Comments

Danial Behzadi June 26, 2021, 1:19 p.m. UTC | #1
Any news on this?
Should I do any additional step?
Danial Behzadi June 26, 2021, 7:43 p.m. UTC | #2
Changed a little in LibreMiami packaging event
Raghav Gururajan June 26, 2021, 8:06 p.m. UTC | #3
Thank you for the contribution.

Pushed as 1f15a6559b.
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 1268ff257a..7ce0ada5ea 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1410,6 +1410,43 @@  the version levels, and check whether any given string is a proper semantic
 version identifier.")
     (license license:bsd-3)))
 
+(define-public python-fire
+  (package
+    (name "python-fire")
+    (version "0.4.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "fire" version))
+       (sha256
+        (base32
+         "0qka44n88y3qcj7xz0k0f3qb4phcg4z0wvd4jcii9lcr6rvbiqn5"))))
+    (build-system python-build-system)
+    (native-inputs
+     `(("python-pytest", python-pytest)))
+    (arguments
+     '(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda _ (invoke "pytest"))))))
+    (inputs
+     `(("python-six", python-six)
+       ("python-termcolor", python-termcolor)))
+    (synopsis "Library for automatically generating command line interfaces")
+    (description
+     "Python Fire is a library for automatically generating command line interfaces
+     (CLIs) from absolutely any Python object.
+
+     * Python Fire is a simple way to create a CLI in Python.
+     * Python Fire is a helpful tool for developing and debugging Python code.
+     * Python Fire helps with exploring existing code or turning other people's
+    code into a CLI.
+     * Python Fire makes transitioning between Bash and Python easier.
+     * Python Fire makes using a Python REPL easier by setting up the REPL with
+    the modules and variables you'll need already imported and created.")
+    (home-page "https://github.com/google/python-fire")
+    (license license:asl2.0)))
+
 (define-public python2-semantic-version
   (package-with-python2 python-semantic-version))