diff mbox series

[bug#49028,v3] Add mda-lv2. * gnu/packages/audio.scm (mda-lv2): New variable.

Message ID 20210622110054.12438-1-t_w_@freenet.de
State Accepted
Headers show
Series [bug#49028,v3] Add mda-lv2. * gnu/packages/audio.scm (mda-lv2): New variable. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Thorsten Wilms June 22, 2021, 11 a.m. UTC
---
 gnu/packages/audio.scm | 33 +++++++++++++++++++++++++++++++++
 1 file changed, 33 insertions(+)

Comments

Xinglu Chen June 23, 2021, 8:46 a.m. UTC | #1
On Tue, Jun 22 2021, Thorsten Wilms wrote:

> ---
>  gnu/packages/audio.scm | 33 +++++++++++++++++++++++++++++++++
>  1 file changed, 33 insertions(+)

LGTM, apart from the commit summary being a little messed up. :)

I don’t have commit access though, so you will have to wait for someone
else to merge it.
Efraim Flashner June 28, 2021, 2:49 p.m. UTC | #2
Thanks. Patch pushed!
diff mbox series

Patch

diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 3885a22e10..22dc71fe50 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -5275,3 +5275,36 @@  Icecast server.")
 generator, generating audio signals out of Linux's /dev/dsp audio
 device.  There is support for mono and/or stereo and 8 or 16 bit samples.")
     (license license:gpl2)))
+
+(define-public mda-lv2
+  (package
+   (name "mda-lv2")
+   (version "1.2.6")
+   (source
+    (origin
+     (method url-fetch)
+     (uri
+      (string-append "http://download.drobilla.net/mda-lv2-"
+		     version ".tar.bz2"))
+     (sha256
+      (base32 "1nspk2j11l65m5r9z5isw8j749vh9a89wgx8mkrrq15f4iq12rnd"))))
+   (build-system waf-build-system)
+   (arguments
+    `(#:tests? #f  ; There are no tests.
+      #:configure-flags
+      (list (string-append "--prefix="
+			   (assoc-ref %outputs "out")))))
+   (inputs
+    `(("lv2" ,lv2)))
+   (native-inputs
+    `(("pkg-config" ,pkg-config)))
+   (native-search-paths
+    (list (search-path-specification
+           (variable "LV2_PATH")
+           (files '("lib/lv2")))))
+   (home-page "https://drobilla.net/software/mda-lv2")
+   (synopsis "Audio plug-in pack for LV2")
+   (description
+    "MDA-LV2 is an LV2 port of the MDA plugins.  It includes effects and a few
+instrument plugins.")
+   (license license:gpl3+)))