diff mbox series

[bug#49142,1/1] gnu: Add pcl.

Message ID 20210620175022.11763-1-mail@davie.li
State Accepted
Headers show
Series Add pcl (Guix packaging meetup) | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

David Dashyan June 20, 2021, 5:50 p.m. UTC
* gnu/packages/c.scm (pcl): New variable.
---
 gnu/packages/c.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)

Comments

Efraim Flashner June 29, 2021, 7:16 a.m. UTC | #1
Looks good. I made one change before pushing it.

On Sun, Jun 20, 2021 at 08:50:22PM +0300, David Dashyan wrote:
> * gnu/packages/c.scm (pcl): New variable.
> ---
>  gnu/packages/c.scm | 20 ++++++++++++++++++++
>  1 file changed, 20 insertions(+)
> 
> diff --git a/gnu/packages/c.scm b/gnu/packages/c.scm
> index 931eb2bf3f..a17bf22f04 100644
> --- a/gnu/packages/c.scm
> +++ b/gnu/packages/c.scm
> @@ -11,6 +11,7 @@
>  ;;; Copyright © 2020 Katherine Cox-Buday <cox.katherine.e@gmail.com>
>  ;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
>  ;;; Copyright © 2020, 2021 Greg Hogan <code@greghogan.com>
> +;;; Copyright © 2021 David Dashyan <mail@davie.li>
>  ;;;
>  ;;; This file is part of GNU Guix.
>  ;;;
> @@ -693,3 +694,22 @@ event-driven, asynchronous network application protocols.")
>  cryptographic primitives for the @acronym{AWS,Amazon Web Services} SDK.")
>      (home-page "https://github.com/awslabs/aws-c-cal")
>      (license license:asl2.0)))
> +
> +(define-public pcl
> +  (package
> +    (name "pcl")
> +    (version "1.12")
> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (string-append
> +             "http://www.xmailserver.org/pcl-" version ".tar.gz"))
> +       (sha256
> +	(base32
> +         "06ly65rq4iyj2p4704i215c8y4rgspwl8sxfaifmf4ahfr30bcz7"))))
> +    (build-system gnu-build-system)
> +    (home-page "http://www.xmailserver.org/libpcl.html")
> +    (synopsis "Portable Coroutine Library")
> +    (description "The Portable Coroutine Library (PCL) implements the

@acronym{PCL, Portable Coroutine Library}

> +low level functionality for coroutines.")
> +    (license license:gpl2+)))
> -- 
> 2.31.1
> 
> 
> 
>
diff mbox series

Patch

diff --git a/gnu/packages/c.scm b/gnu/packages/c.scm
index 931eb2bf3f..a17bf22f04 100644
--- a/gnu/packages/c.scm
+++ b/gnu/packages/c.scm
@@ -11,6 +11,7 @@ 
 ;;; Copyright © 2020 Katherine Cox-Buday <cox.katherine.e@gmail.com>
 ;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 ;;; Copyright © 2020, 2021 Greg Hogan <code@greghogan.com>
+;;; Copyright © 2021 David Dashyan <mail@davie.li>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -693,3 +694,22 @@  event-driven, asynchronous network application protocols.")
 cryptographic primitives for the @acronym{AWS,Amazon Web Services} SDK.")
     (home-page "https://github.com/awslabs/aws-c-cal")
     (license license:asl2.0)))
+
+(define-public pcl
+  (package
+    (name "pcl")
+    (version "1.12")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "http://www.xmailserver.org/pcl-" version ".tar.gz"))
+       (sha256
+	(base32
+         "06ly65rq4iyj2p4704i215c8y4rgspwl8sxfaifmf4ahfr30bcz7"))))
+    (build-system gnu-build-system)
+    (home-page "http://www.xmailserver.org/libpcl.html")
+    (synopsis "Portable Coroutine Library")
+    (description "The Portable Coroutine Library (PCL) implements the
+low level functionality for coroutines.")
+    (license license:gpl2+)))