diff mbox series

[bug#49028] gnu: Add mda-lv2

Message ID 20210620162612.7f6f58f837925c8abfd2d840@freenet.de
State Accepted
Headers show
Series [bug#49028] gnu: Add mda-lv2 | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Thorsten Wilms June 20, 2021, 2:26 p.m. UTC
I fixed the description and license. I think there’s no need to change
away from the tarball, as it’s actually an official release on the code
author’s domain.

Thanks, Xinglu Chen!


* gnu/packages/audio.scm (mda-lv2): New variable.
---
 gnu/packages/audio.scm | 35 +++++++++++++++++++++++++++++++++++
 1 file changed, 35 insertions(+)

+a few instrument plugins.
+   (license license:gpl3+)))

Comments

Xinglu Chen June 22, 2021, 7:44 a.m. UTC | #1
On Sun, Jun 20 2021, Thorsten Wilms wrote:

> I fixed the description and license. I think there’s no need to change
> away from the tarball, as it’s actually an official release on the code
> author’s domain.

Fair enough.

> Thanks, Xinglu Chen!

You are welcome!

Note that things that shouldn’t be part of the commit message should be
put below the ‘---’ line.  The subject should also contain “[PATCH v2]”
to reflect that this is the second version of the patch, you can pass
the ‘--reroll-count=2’ to ‘git send-email’.

Also, I am not able to apply the patch, ‘git am’ reports:

  Applying: gnu: Add mda-lv2
  error: corrupt patch at line 12
  error: could not build fake ancestor
  hint: Use 'git am --show-current-patch=diff' to see the failed patch
  Patch failed at 0001 gnu: Add mda-lv2
  When you have resolved this problem, run "git am --continue".
  If you prefer to skip this patch, run "git am --skip" instead.
  To restore the original branch and stop patching, run "git am --abort".

Your previous patch did apply cleanly, did you do anything differently?

> +(define-public mda-lv2
> +  (package
> +   (name "mda-lv2")
> +   (version "1.2.6")
> +   (source
> +    (origin
> +     (method url-fetch)
> +     (uri
> +      ;; Tarball from gitlab lacks waflib directory content, so take
> it from
> +      ;; drobilla.net.

This comment isn’t accurate anymore, so there is probably no need for
it.

> +      (string-append "http://download.drobilla.net/mda-lv2-"
> +		     version ".tar.bz2"))
> +     (sha256
> +      (base32
> "1nspk2j11l65m5r9z5isw8j749vh9a89wgx8mkrrq15f4iq12rnd"))))
> +   (build-system waf-build-system)
> +   (arguments
> +    `(#:tests? #f  ; There are no tests.
> +      #:configure-flags
> +      (list (string-append "--prefix="
> +			   (assoc-ref %outputs "out")))))
> +   (inputs
> +    `(("lv2" ,lv2)))
> +   (native-inputs
> +    `(("pkg-config" ,pkg-config)))
> +   (native-search-paths
> +    (list (search-path-specification
> +           (variable "LV2_PATH")
> +           (files '("lib/lv2")))))
> +   (home-page "https://drobilla.net/software/mda-lv2")
> +   (synopsis "Audio plug-in pack for LV2")
> +   (description
> + MDA-LV2 is an LV2 port of the MDA plugins.  It includes effects and
> +a few instrument plugins.

The description should be put inside double quotes :)

Could you send a v3?
diff mbox series

Patch

diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 3885a22e10..e352f797da 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -5275,3 +5275,38 @@  Icecast server.")
 generator, generating audio signals out of Linux's /dev/dsp audio
 device.  There is support for mono and/or stereo and 8 or 16 bit
samples.") (license license:gpl2)))
+
+(define-public mda-lv2
+  (package
+   (name "mda-lv2")
+   (version "1.2.6")
+   (source
+    (origin
+     (method url-fetch)
+     (uri
+      ;; Tarball from gitlab lacks waflib directory content, so take
it from
+      ;; drobilla.net.
+      (string-append "http://download.drobilla.net/mda-lv2-"
+		     version ".tar.bz2"))
+     (sha256
+      (base32
"1nspk2j11l65m5r9z5isw8j749vh9a89wgx8mkrrq15f4iq12rnd"))))
+   (build-system waf-build-system)
+   (arguments
+    `(#:tests? #f  ; There are no tests.
+      #:configure-flags
+      (list (string-append "--prefix="
+			   (assoc-ref %outputs "out")))))
+   (inputs
+    `(("lv2" ,lv2)))
+   (native-inputs
+    `(("pkg-config" ,pkg-config)))
+   (native-search-paths
+    (list (search-path-specification
+           (variable "LV2_PATH")
+           (files '("lib/lv2")))))
+   (home-page "https://drobilla.net/software/mda-lv2")
+   (synopsis "Audio plug-in pack for LV2")
+   (description
+ MDA-LV2 is an LV2 port of the MDA plugins.  It includes effects and